Add tag option not showing

Hi everybody !

i’m struggling with a small problem - tag related.
The general search is really not good. So, in order for us to quickly find what we are looking for, we thought of putting some tags on root pages.

from what i understand, tag are by default preinstalled on xwiki.

i tried to find the tag [+] option at the botom of the page as it’s said on https://extensions.xwiki.org/xwiki/bin/view/Extension/Tag%20Application

but it doesnt shows up. i double checked if the plugin was installed and it is.
Do i miss something ? i feel a bit idiotic to create a topic on a basic subject like that…

Any help would be appreciated !
Best regards,
Theo

Hi,

are you logged-in when you check for this option? Can you share which version of XWiki you are using?

Thanks.

Hey, i’m logged in with administrator privileges for sure !

sorry, i forgot to give you the xwiki version i’m running :
12.6-1

Thanks for the prompt answer :slight_smile:

It’s actually an issue that has been fixed on next versions: Loading...
You should upgrade your wiki either to 12.6.2 or 12.7.1.

Ok thanks for the intel !

how did i not see that jira case…

I’ll do the upgrade and confirm on this thread after.

1 Like

TAG is now available, thank you, have a nice day
Theo.

do we have a way to search via tags in the main search bar or its only via RSS ?

You can search for tags using the solr-based search, see https://extensions.xwiki.org/xwiki/bin/view/Extension/Solr%20Search%20Application#HSearchSyntax

Example: https://www.xwiki.org/xwiki/bin/view/Main/Search?sort=score&sortOrder=desc&highlight=true&facet=true&r=1&f_type=DOCUMENT&f_locale=en&f_locale=&text=property.XWiki.TagClass.tags%3Arendering

i.e. to search for all pages with the rendering tag: property.XWiki.TagClass.tags:rendering

Thanks for that.
I’ll look into it ASAP.
Best regards

hello. i’m using xwiki 13.3 and i’m newly experiencing missing the possibility to add tags to a page. the old ones are still there (checked in object editor mode) and are also still displayed in the tag cloud. is there a jira that i’m missing? thank you in advance!

Same for me @13.5. Old Tags are present only when I click on Dashboard. Everyhwere else, there is simply no “Tags” at the bottom of the articles (and hence no “+” to add more Tags).

Can anyone who’s at v13+ check?

I already tried looking for an option in the settings but couldn’t find anything related to tags. There are also no extansions, as this probably is a integrated function of xWiki. I could not find any open issue at jira about this, could it be, that this bug hasn’t been noticed yet?

EDIT: I should probably add more information.

  • I’m using the official xwiki:stable-mysql-tomcat docker image.
  • Freshly installed and imported old Data from an older instance via the import tool.
  • I had problems with images not being imported, so I had to move them by hand from my old backup to the new instance after the initial import.

Hello everyone, I’m experiencing the same problem:

  • no add tag option at the page bottom
  • no tags shown at the page bottom
  • tag cloud still works for “old tags”, but i’m unable to add tags to newer pages or to edit tags in existing pages

I’m using XWiki 13.10.9
Is there a solution?
Thanks