Excel plugin doesn't work

Following the tutorial on the Excel Plugin page.
It says that after installing it I can view the contents of my file with: $xwiki.calc.getTable("sample.xls", "1", "A1-B10").
And to verify if the installation is correct, I can type $xwiki.calc. Neither of them work. When I type {{velocity}}$xwiki.calc{{/velocity}}, I just get the text $xwiki.calc:

Extensions Manager says that the Excel Plugin is installed:

I checked out the comments on the page of the tutorial and someone said there:

$xwiki.ExcelPlugin should be updated to $xwiki.calc as this is the name of the plugin on a newer XE > 2.1.1

Does it mean that the name of the plugin changed again? What’s the new name?

I checked out the Excel Plugin repository and found the ExcelPlugin.java file. There’s this code:

public class ExcelPlugin extends XWikiDefaultPlugin
    public ExcelPlugin(String name, String className, XWikiContext context)
        super(name, className, context);

    public String getName()
        return "calc";

So it is created with some name in the constructor, but it always returns “calc” when asked about its name with getName(). But with what name it is actually created in the wiki? And which one of those matter to access them from the Velocity scripts? Is it the one passed to the constructor or the one in the getName()? How to figure it out, how to make it work?

I’m using the xwiki-platform-distribution-jetty-hsqldb-14.9 distribution on Windows. I’ve also tried xwiki-platform-distribution-jetty-hsqldb-14.7 and xwiki-platform-distribution-flavor-jetty-hsqldb-13.10.10 distributions with the same result for {{velocity}}$xwiki.calc{{/velocity}} after installing the Excel plugin from the Extension Manager.

Fixed by cloning the plugin Github repository, then manually building and installing the Excel plugin together with the jxl dependency from the local Maven repository. Now it works.