LDAP Authenticator not working

I cannot seem to get the LDAP Authenticaton extension installed on my Ubuntu instance of XWiki.

  1. I installed the LDAP Authenticator using the Extension Manager.
  2. I copied the /etc/xwiki/xwiki.cfg file to make a new config file named /etc/xwiki/xwiki.cfg.ldap.
  3. I renamed the /etc/xwiki/xwiki.cfg file to /etc/xwiki/xwiki.cfg.save
  4. I created a symbolic link /etc/xwiki/xwiki.cfg > /etc/xwiki/xwiki.cfg.ldap
  5. I followed the instructions and added all the LDAP configuration to the new xwiki.cfg.ldap file and changed the config settings as needed.
  6. When it came to logging I tried to use the Admin UI method but I cannot find the package org.xwiki.contrib.ldap in the list of packages.
  7. I restarted Tomcat8 (sudo service tomcat8 restart) and saw the system initialize.
  8. I looked at the Admin UI > Logging and I still not not see the package org.xwiki.contrib.ldap
  9. I also do not see any LDAP entries in the /var/log/tomcat8/Catalina.yyyy-dd-mm.log file.

I’m not sure what else I need to do to complete the extension installation.

This suggest the LDAP authenticator is not used at all. Are you sure you have:


in xwiki.cfg ?

Thanks @tmortagne that was indeed the issue preventing the LDAP packages from not showing in the Logging UI. Unfortunately it looks like there is still more config to be corrected because I’m not seeing any LDAP related entries in the Catalina log file with logging for the LDAP packages set to TRACE.

With tomcat9 on Ubuntu 18.04, by default there is no catalina.out, instead look in syslog with the identifier tomcat9

Do you see XWiki related logs at all ? You should have stuff like Solr initializing, etc.

Note that I do have a /var/log/tomcat9/catalina.out file on Debian Buster. I did not try on Ubuntu 18.04 but I’m very surprised that Ubuntu customized that.

I was also surprised, I was not the first to discover this.