Missing buttons when switching from localhost to wiki.domain.local

Hello Everyone,

I’m trying to setup the xwiki but I’m facing an annoying issue regarding DNS name.

When I want to use wiki.domain.local:8080/xwiki instead of localhost:8080/xwiki all buttons are gone, so home, menu, search etc…

I’m using the latest version on Tomcat 9.

Thank you in advance for your help.

Regards

Can you show us a screenshot so that we better understand what happened?

Sure !
using localhost in the url
localhost
using wiki.domain.local in the url
local

Looks like an issue with the font icons (Font Awesome icon theme). What happens if you clear the browser cache and reload the page?

Indeed, when I switch to Silk I can see them (I changed the theme back to XWiki.DefaultSkin and the color theme but didn’t try to change that).

I also noticed that button and arrows from the navigation pane are gone and this event with the Silk icon theme
localhost
localhost

wiki.domain.local
local

I tried to clear my browser cache but no luck.

Found the issue, setting the site in trusted sites solved the issue, I’m on the test server directly which is not really configured for internet browsing.