OfficeImporter and splits

Hi all

First, thanks to the devs for this marvelous piece of software. Kudos!

(edited that thing a bit, because some things sorted out with some cleanup)

I wanted to import some word document (docx). The import itself works fine, but the splitting behaves weirdly: I can check “Split Document”, but I can’t select the heading level. The browser changes my mouse cursor to a “no way!” sign and refuses to pass my clicks through to the list.

Our environment:

Server version: Apache Tomcat/8.5.15
Server built:   May 5 2017 11:03:04 UTC 
Server number:
OS Name:        Linux
OS Version:     3.8.13-118.18.4.el7uek.x86_64
Architecture:   amd64
JVM Version:    1.8.0_131-b12
JVM Vendor:     Oracle Corporation

Any idea/pointer/thought is highly appreciated.



That’s because this forum is new. You can search the old mailing list here: (linked from

I know, but I didn’t know how new it was :wink: While hoping for an answer, I’ll search the archives over there.

You’re right. I’ve now added the info on the page:

1 Like

I found this in the mailing list archive:

It wasn’t even accepted. That’s exactly how it looks like on our system.

About this, there’s no acceptance, it’s most likely that whoever posted didn’t follow what Nabble said, i.e. that you used to need to register on the mailing list before posting. That’s one reason we’ve now moved to a real Forum: to make it simpler for user to post messages! :slight_smile:

About the issue - is this something I have to live with?

Of course not, but I haven’t responded because I don’t have the solution right now. I’ll need to try to reproduce and I don’t have the time right now. If you’re patient a bit more I’m sure someone will respond (could even be me if you give me a few hours/days ;)).

1 Like

Sorry for being impatient :slight_smile:

@abonhote I tested it and I can reproduce on XWiki 8.4.5. It would be great if you could open a jira issue at so that someone can fix it! Thanks for finding this problem.

Hi Vincent




PS: I reused your screenshot.

Seems to be solved - is there a way to get this into my 9.4 installation without having to reinstall everything?



If you check the commit tab of you can see what was modified.

Here are the changes:

So you could do the exact same changes in the XWiki.OfficeImporter page of your wiki.

Hi Vincent

Bear with me - I tried quite some things to do that. “find” on the command line only finds xar and xed files containing the name “office”. Where the heck is this file?

It’s a page in your wiki. The reference of the page is XWiki.OfficeImporter, which translates into .../XWiki/OfficeImpoterin the URL.

But see to understand how to navigate to a page.

Been there, edit -> source, but no line 283 with “maybeDisableSplitOptions”. The file modified on github is an xml, whereas (from my understanding) the thing I’m editing here is velocity. Completely wrong?

it’s because you need to edit the objects on this page and not the content. The maybeDisableSplitOptions text is in the JavascriptSkinExtension object.


1 Like

What you see on GitHub are the sources which get build into an executable (XWiki). The XML is the way we store content of wiki pages on the filesystem. When built, they’re loaded in XWiki and stored in the database.

Thanks a ton! Works!