I’m personally mixed on the general proposal. I’m ok with removing an unnecessary class, but not sure about the names. Basically I’m wondering if we shouldn’t call
User the new
I understand that you call it
UserConfiguration because it’s a
ConfigurationSource, but I’m wondering if it wouldn’t be easier to understand it as a
User object for semantic reason.
The first example I have is that
UserManager#create returns a
UserConfiguration which I find already a bit confusing.
I’m a bit afraid that we’d need the concept of User for future APIs and to be stuck again because we need to break again some APIs because we don’t have it. Now I don’t have real examples of usage right now.