Replace -PsnapshotModules by -Psnapshots

Hi devs,

I’d like to configure the XWiki Maven remote repo in the pom.xml of our top level commons pom when we build snapshots (since we don’t release snapshots to maven central).

In order to reuse the existing “snapshotModules” profile, I”m proposing to rename it to something more generic: “snapshots”.

I’m doing the work now. Please reply quickly if you see a problem.


+1 for the general idea but I was thinking more about “snapshot” than “snapshots”

+1, same as Thomas.

Done, I’ve used “snapshot” and it’s documented at