Search suggestion does not show results

Hi,

my XWiki 10.3 Installation does not show any search suggestion. But if i hit in the search box, the search result page opens and i see some pages. The searchengine is Solr.

Thanks
Matthias

Hi, this is probably because there’s a Solr-related page requiring Programming Rights. This is strange though because on https://www.xwiki.org/xwiki/bin/view/Documentation/AdminGuide/Upgrade#HUpgradingwikidocuments I don’t see any Solr page in the list (in the warning).

@mflorea any idea?

Check the Search Suggest Administration section http://extensions.xwiki.org/xwiki/bin/view/Extension/Search+Application#HSearchSuggestAdministration to see if the search suggest sources are present and activated. You can also try to clear the browser cache as the search suggest sources are dynamically injected in the search suggest JavaScript code and maybe you have an older version of this JavaScript code cached in your browser.

@vmassol I don’t know any Solr-related page that requires PR. The PR issue Loading... has been fixed some time ago.

Thanks for your answers. I’ve checked the activation of search suggestion. Search suggestion is activated (default). The strange is, that i get no suggestion for my own document content, but for some document names. And if i type “screen” i get a suggestion for the “Help Applications Contributors Charlie Chaplin” site!

The is a search suggest source that looks into page names and one that looks in page content. Maybe the pages that don’t appear in the suggestions have not been indexed yet. Check the indexing queue size in the search administration section.

That’s expected because that page contains “screen” in its content so the “Page Content” search suggest source should find it.

I’ve checked the the search administration. There are 0 entries in the queue. I tryed reindexing or delete the index, but no suggestion. On the other hand the index seems to be ok, because the “normal” search delivers search results.
Can this a language problem be? I use german as default and english as the second language. But it is not a multilingual wiki. I use xwiki for it-documentation, so some content is in german and some other (such as code examples) are in english.

Hi,
after some Testing, i know the reason. My pages have the language “de_DE” set. I’ve exported a page as xar, changed the tag to “en” and imported the page. Then set the language under Content->Localisaton to English. Now the page was suggested :slight_smile:
Can it be, that the search suggestion runs in english only? And how can i change this to german?

I don’t think so. It searches in the page translations that match the current language.

#set ($discard = $filterQuery.add("locale:(""$xcontext.locale"" OR """")"))

So yes, if the current language is en then the de_DE pages that don’t have an en translation will not be found.

Note that the same configuration is used on the main search page so you should have the same problem there.

Hi,

I also have search problems related to translation :disappointed_relieved:.

My Wiki is not set to multi-languages mode (like described above by @jammerhund) and all pages contents are written in french but it looks like there are (old ?) pages which were and are still set to “en” causing search problems (some pages are not shown by default in results).

How can I toggle a page from one language (en) to an other one (fr) without modifying its content? (purpose: removing everything tagged as (en) while keeping all wiki content both for display and easy search).

Thanks fo your answer,

See http://www.xwiki.org/xwiki/bin/view/Documentation/UserGuide/Features/PageEditing#HDefaultLanguage .

Thanks. I have already played with this “language properties panel” on several pages.

Yet my ideal process to toggle all pages from source (en) to destination (fr) is below but … it misses some parts (around 50%):

  1. In Wiki admin : Activate multilingual option, declare : default language to fr and available languages to fr & en
  2. search all pages which are in (en) => how to perform this easily?
  3. open page then set default language to (fr)
  4. destroy (en) page (ie remove (en) version of the page) => how to perform this?
  5. In Wiki admin : disable multilingual option and set (fr) only.

Many thanks in advance for your help to fill the blanks above :rofl:.

This should do it I think:

http://<server>/xwiki/bin/view/Main/Search?highlight=false&r=1&sortOrder=desc&sort=score&text=*%3A*&f_type=DOCUMENT&facet=true&f_locale=en

If you know you have hidden pages in English you should also enable “show hidden pages” from your user profile.

First make sure the current language is English. If English is the default translation of the current page, i.e. if you see “en” in the Default Language field from the edit mode then you don’t have to do anything else than changing “en” to “fr”.

Thanks Marius, url provided, if search engine is set to Solr, returns all pages and I can see the ones which are in english … I will have a lot of work to toogle them to french.

I will let you know,