Upgrade to 12.6 and some pages are not indexed. How do I re-index the Wiki

After upgrade to 12.6 and import from another 12.6 install, the index is missing many pages.

How do I re-index. Have searched and can not find.

It took me some time to find “Solr Administration” section. It’s in the Global Administration and title is different (see my attachment:chrome_SKEI1bdXLy.png)

Where do I initiate a complete re-index of the wiki?


Found Reindex. Sorry to bother everyone

Global Admin
Search again [default search engine

under Action (scroll to reindex)
WIKI Home or if farm must have rights


Thinks for a second and get green success box with message Reindex successfully triggered

Search comes back and under

Status, first it count from zero up to number of pages/items to index

Status … Queue size count down of number of items left to index

Also it resets Action to "add to index and wiki entire farm

For 20,000 items takes about 10 minutes.

Well, never a dull moment.

After the reindex completed

the links on various pages to other pages works
no ? next to linked words on pages

For example (we are Not for Profit) and I am looking at the page “Donate”. I got to the Donate page from a link on another page. Donate it is in the home directory which is where I put it.

However, if I use the magnifying glass upper right, and type in


I get no results

Help please … before re-index the magnifying glass then Donate found pages and now I get No Results! even though the page Donate exists and is displaying on the page where I enter Donate after clicking on the magnify glass.

Additional information

  • for greater certainty, prior to reindexing the magnifying glass question worked perfectly with dozens of hits for most words entered. It was only after an import that some words had ? next to them and that is why I reindexed (and it did fix the ? next to words on some pages) but now magnifying glass questions do not return results

  • any links within pages I created to other pages within the wiki work. And faster too.

  • have created pages with the words Platform and when I use the magnifying glass and enter Platform, I get results but only XWIKI oriented pages … ie not a page that I created.

  • if I enter Macro in the magnifying glass field, then get many results but only XWIKI specific pages

Additional information on reindex issue in 12.6

I have an account on XWIKI cloud with the similar pages that I have running on Pi.production Standard 12.6

When I reindex on XWIKI cloud account, it works perfectly – exactly as I would expect.

Thanks for your help

Bit more info

I exported using created and modified my production account. Imported into my Xwiki SAS account and started a reindex.

10,727 items selected to re-index on my SAS account

Did the same on my production account but there was 14,796 items to be re-indexed on my production (standard install / 12.6)

Conclusion: Reindex is broken in 12.6 ??

I’ve just downloaded and installed a clean XWiki 12.6.1 and I’ve cliked “reindex” and it worked fine.

Make sure you set up the permanent directory correctly and never use a temporary directory for it, see https://www.xwiki.org/xwiki/bin/view/Documentation/AdminGuide/Configuration/#HPermanentDirectory

Thank you.

I am not a technical person. Just the site manager. The link you provided is way over my pay grade, knowledge and skill level. However I did copy paste the mini program suggested in the documentation to generate the Current Permanent Directory which you said may be incorrect. Here is what was displayed when I opened the test page I created.:



I personally have No clue if /var/lib/xwiki/data is correct. - even looking at the documentation link you provided.

This is what I know because I personally did all of the following:

  1. Personally I do not have the skill set to do the unix level upgrades to 12.6. That was done by a seasoned expert on the Pi. operating system. And hence he did the unix component to upgrade both Pi.production and Pi.backup to 12.6.1 After that was done I tested both Pi.production and Pi.backup and they seemed fine.

Initially he also installed the initial Standard Xwiki on both Pi.production and Pi.backup computers (that subsequently worked for months before upgrade to 12.6).

  1. Before upgrade to 12.6 I had never used reindex (because I did not know reindex existed).

  2. For months before upgrade to 12.6 both Pi.production and Pi.backup computers were able to return user created pages (and xwiki pages) when, for example, Donor or Platform was entered (and dozens and dozens of other words) into the magnifying glass field. In other words the hourglass entered words / questions worked perfectly in Pi.production and Pi.backup. Really well. awesome.

  3. Pi. Production and Pi.backup were both upgraded to XWIKI 12.6.1. After upgrade to 12.6 I honestly do not know if hourglass questions worked because I did not test. I only skimmed pages and tested a dozen or so links within random pages and ALL the links tested worked perfectly as expected.

4 After the upgrade to 12.6.1, I satisfied myself that both Pi.production and Pi.backup worked as I would expect and they did.

Then I did do an export of Pi.production using (created and modified and select all) and then imported all the selected pages to Pi.backup. [Global Administration export import is another issue]

  1. Pi.backup … After importing Pi.production, I checked Pi.backup and a quick look, everything looked OK however there were a few links within the user created pages that had link? behind it. Ie the page cross reference after import was imperfect. This has happened before and no big deal. Normally I fix one by one by entering [link word and that has always fixed the ?.

  2. Pi.backup … This time I found “reindex” after serious research and I followed the instructions to reindex in the Global Administration Search area. I could see the item count increase and then decrease. It certainly looked like the reindex was working. It also changed the other Searh input fields back to the initial setting and looked perfect as it worked. I had no inkling that reindex was not working properly.

After the reindex finished, I checked the user created pages to see if the link? had been fixed and they had. I thought GREAT, AWESOME I did not need to fix link? one by one

7.Pi.backup :: Later in the day I searched using the magnifying glass for the words Donor and the word Platform. At the time I did the search the screen in front of me was the Donor page and later the Platform pages I created. So I knew these specific user pages existed and yet when I searched using the magnifying glass field and entered Donor and then Platform and several other words that I knew existed they all returned no items found.

  1. Pi.backup :: When I used the magnifying glass search for the word Platform, some XWIKI pages did get selected and shown. However no user created pages with Platform appeared.

  2. I posted my reindex issue on the XWIKI forum and did not have a response the next day. I assumed that there was an easy fix and I goofed somehow. Thank you Vincent for responding. I have seen your name on dozens of documentation pages. Thank you for your help.

  3. Pi.backup :: To see if I could fix the index issue, I imported to Pi.backup the Pi.production export used the last time - again using exactly the same options.

This time I did not not use the reindex on the Pi.backup. .

I searched for Donation and it came up with multiple user pages (exactly as it should have). And I searched for many other words that I knew were in the wiki and they all showed up. Perfect. Problem fixed.

And hence from my perspective, the index issues with Pi.backup were fixed and I noted to myself to never to use reindex again because it destroyed my user created pages index.

I know that with your expertise, you will know exactly what the issue is. I look forward to your solution and appreciate your help.

Thanks for your help.