Upgrading extensions fails (Solved)

#1

Hi,

I have several extensions that reject an upgrade. In the screenshot I have an example what goes wrong.
Is there a best practice how to upgrade/uninstall extensions that stuck in the process ?

Ciao
Matze

Auswahl_513

0 Likes

#2

Activity Stream is deprecated and is not part of XWiki Standard flavor dependencies anymore. Instead of upgrading it you should uninstall it since otherwise it will conflict with the new notification system.

0 Likes

#3

I have removed all Activity Plugins from the subwikis. But when trying to
Repair/Uninstall it in the main wiki I get this:

Auswahl_519

0 Likes

#4

Repair is pretty much the same as install (it will try to repair it by finding missing dependencies). Click on the arrow and you will find “Uninstall”.

0 Likes

#5

Unfortunately is shows the same behavior when trying to uninstall.

0 Likes

#6

I really doubt you get the exact same error.

0 Likes

#7

As always you are right. The error look similar but it is not.

Auswahl_521

0 Likes

#8

It works now.
The cause was an old Blog API that has some dependencies that does not work. After Installing the actual Blog Application over the existing one 9.3.3 everything works as expected.

The Repair button starts working and after it is finished the plugin is gone.

Thank you for your support !!!

0 Likes