Url adds :80 in sub-wiki

Hi,
I’ve just created a sub-wiki on a 11.8.1 version, and the url are wrong:
a :80 is systematically added to the host part of the url.
The domain is set with https, and the url begins with https://
Where can I config that?

Check the wiki descriptor (from the wiki administration), both for the main wiki and for the created subwiki.

Thanks for answering, I’ve tried this, but didn’t get results (maybe I set wrong parameters).
The wiki is hosted http behind nginx proxy https.
The strange part is that the main wiki works well while the sub wiki encounters this problem.
I think it comes from nginx conf

subwiki loaded url are like:
loaded page:
https://xwiki.mydomain.tld/xwiki/wiki/subwikiname/view/Main/ → 200
https://xwiki.mydomain.tld:80/xwiki/wiki/subwikiname/skin/skins/flamingo/print.css?cache-version=1570470250000&skin=XWiki.DefaultSkin&colorTheme=ecolesenligne%3AFlamingoThemes.Iceberg → 200
→ the css url gets a :80 added (but gets loaded)
→ script href gets also a :80 added, but fails loading.

Ideas welcome, but I’ll try to check better my hosts and nginx configuration, and ask more specific questions, or give more details if I get some.

Ok, one new clue:
The first get request is without :80 in the url.
Then amongst the subsequent other get request, some have a :80 added, and nearly all of them are specific to the subwiki: they have a /wiki/ substring inside.

Another point is that I have some settings in /usr/lib/xwiki/WEB-INF/xwiki.cfg
xwiki.home=https://xwiki.mydomain.tld/
xwiki.url.protocol=https
that maybe override any description setting?

I wonder if there are server config files/entries for subwikies, and why and how this :80 is added in subwiki specific URL.

Ok, in my nginx configuration, this line was commented (probably by stupid me).

proxy_set_header X-Forwarded-Host $host;

The main wiki works without it, but subwiki don’t.

This was the problem.

Yes this has priority over main wiki descriptor.

That’s because you forced main wiki host in xwiki.home.