Wiki Page broken entry due to / in title when created


#1

slash%20in%20name

If i try to re-create the structure, i still cant delete it.
Any idea if there is a postgre command that can change that / into a - or something to fix it? The thing is, there are no pages associated with it, so its just displaying this null filename/location

I made my way into the postgres xwiki via command line, then decided this is a bad idea.

I also tried to enable " / " in apache, and then tried to re-make that exact location, but it didnt work.

How can i edit this title so it can become editable or remove it from wherever it is derived from?


#2

See https://www.xwiki.org/xwiki/bin/view/Documentation/AdminGuide/Installation/InstallationWAR/InstallationTomcat/#HAllowing222F22and225C22inpagenames

If you have apache in front make sure to read the end of the section I linked.
Thx


#3

Thank you for the reply!

I did try that last night, I put both of these under JAVA_OPTS as i could not find CATALINA_OPTS anywhere.

Is it ok to use JAVA_OPTS and not CATALINA_OPTS?

JAVA_OPTS="-Djava.awt.headless=true -Xmx1024m
-Dorg.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true
-Dorg.apache.catalina.connector.CoyoteAdapter.ALLOW_BACKSLASH=true"

I am running behind nginx reverse proxy for https. Is nginx going to get in the way? (using very basic config)

When i did this, it still didnt work though. I restarted tomcat, waited for the 10 min or so it needs to get going, and i was still not able to edit it.

Thanks!