9.11.4 Clean Install Permission Problems

Hi everyone,

while doing a clean install of XWiki 9.11.4 WAR Package I’m getting lots of errors during the flavor installation.

2018-04-04 17_19_18-XWiki - XWiki - Distribution

2018-04-04 17_18_46-XWiki - XWiki - Distribution

2018-04-04 17_19_29-XWiki - XWiki - Distribution

2018-04-04 17_20_06-Home - XWiki

I installed XWiki 9.11.2 some time ago on a different machine with the same settings/environment and it worked.

My server runs:

Jetty 9.4.8.v20171121
PostgreSQL 9.6.7

Any ideas?


This is weird, it’s like it was not using your registered administration user. Trying to reproduce.

I just tried but I could not reproduce so I’m no sure how you ended up in that situation (it’s also the first time I see something like this reported). You were asked to create an admin user before installing the Flavor and this user id was not Admin, right ?

Any chance you have some customization or something in front of XWiki that could mess with the session ?

I will check the code to make sure it does not even try to install if context user is not authenticated but for now I would suggest to try again from scratch…

Hey Thomas, thanks for your reply.

Today I checked everything twice and even did a total clean install of PostgreSQL, Jetty and XWiki.

However the problem still persisted. Logs were clean and I had no clue what causes the problem.

I also increased CPU and RAM since it runs on a Virtual Machine and tried a total non-customized install in the standard jetty.base

Then after fiddling and tweaking for a while I found a rather unusual solution :slight_smile:

  1. Start XWiki Setup and wait until first dialog is loaded
  2. Close browser
  3. Open browser and call XWiki URL again

-> Admin Account creation dialog shows and no more permission problems during flavor installation

Here you have some more screenshots which show some weird thing going on with the variables:

Maybe it helps…

2018-04-05 16_17_01-Microsoft Edge

2018-04-05 16_13_22-XWiki - XWiki - Distribution

This is the exact system setup I’m using:

WIN Server 2012 R2
Jetty 9.4.9.v20180320
PostgreSQL 9.6.8
Java 8u162
Firefox 59.0.2 (64-bit)
JDBC Driver postgresql-42.2.2.jar

JIRA gave me


Do you think it could be related?

Are you saying that when you have the issue you don’t even get a step asking you to register an Admin user ?

And you don’t have anything in the log ?

I doubt it has anything to do with Windows even if it’s indeed not the most tested environment.

I tried to upgrade the demo package to 9.4.9 (current version is 9.4.8) recently and I got several blockers issues and did not had the time to investigate. The error I got did not had much to do with what you got and were most probably due to some change we need to make in our setup but it did not even pass the init for me anyway so you might want to try 9.4.8.

If you plan to use Jetty you could also simply use the pre-configured “ZIP Package” and change the database configuration in it to point of PostgreSQL instead (the part which is not recommended for production is mostly the pre-configured HSQLDB database). At the very least using this package will tell us if it’s related to Windows or you database setup.

Definitely not.

In any case if you can reproduce all the time and can explain how to then it would be great if you would create an issue on https://jira.xwiki.org/browse/XWIKI.

After further investigation I finally found what was causing the problem.

I simply forgot that the DB was installed on a different partition and user permissions for that differed :sweat_smile:

It runs like a charm now.

Thanks for your assistance.

Keep up the good work!

OK, glad it finished like this :slight_smile: