After update from 12.10 to 13.10 no access to sub xwiki

after update from xwiki 12.10 latest to 13.10 latest i have no more access to the sub xwiki.
The Problem is, if i step to the sub Xwiki the URL changed from https to http.
Our Websites are only available over https but xwiki change that for the sub Xwiki to http.

So after change the URL to https i can Access to the sub xwiki but there are no more documents available. I have the name of them but xwiki tells me he can’t find any document if i try to open them.

How can i change that two problems?

Many thanks in advanced and with you a happy new year!
best regards

The documents are available but the path of them has been changed.
I have access to the documents over Search Function.
How can i fix that?


in the list of Wikis, you can click on “Edit” link which will drive you to a page with all information about the subwiki, including if it should use ssl or not, and which URL it should use. See:
You should check those settings first.

Now that’s surprising if those page have been modified during the upgrade, maybe you got some issues when merging changes in some configuration files during the upgrade?

the ssl setting was set before and it’s already set now.
The pages path are looking like this:

But the correct path needs to be this one: https://server/wiki/rhxwiki/view/TL-Benutzerverwaltung/
The different is the “bin”.
On 12.10 everything is working but on 13.10 both things ssl URL and the path for pages are changed.

On upgrade the xwiki.cfg, and xwiki-tomcat has been changed and i have made a backup before and insert some old settings like LDAP and openoffice path.
After update i have restart the server an do the updates of flavore etc.

Is there anything else what i can do?

Double check if there is difference in xwiki.cfg before and after the upgrade in the URLs section, see: xwiki-platform/xwiki-platform-tools/xwiki-platform-tool-configuration-resources/src/main/resources/xwiki.cfg.vm at master · xwiki/xwiki-platform · GitHub
In particular check the values of {{xwiki.servletpath}} and {{xwiki.defaultservletpath}}.

Good Morning Surli,
both settings are commented out in the old and the new xwiki.cfg

# xwiki.servletpath=

many thanks for helping

GM again,
i have checked again the xwiki.cfg, xwiki-tomcat9.xml, hibernate.cfg.xml, and web.xml with the old Xwiki 12.10 and the only one how looks a little bit different is the wiki-tomcat9.xml
Old one:

Context path=“/” docBase=“/usr/lib/xwiki” containerSciFilter=“org.apache.tomcat.websocket.server.WsSci|org.apache.jasper.servlet.JasperInitializer”>

New one:

Context path=“/xwiki” docBase=“/usr/lib/xwiki” containerSciFilter=“org.apache.jasper.servlet.JasperInitializer”>

Everything else are looking good to me.
Also the problem with the documents are occure on all xwiki (main and sub)
If i look at the left menu for example the taskManger the URL looks like this:

Is there anything else what I can check?

Many thank’s in advanced

Hello @all,
I have tried now again an update from 12.10 to latest 13.10.6.
Still have problems with open my Subwiki because that one open the subwiki without https://.
The SSL Seting for the SubWiki is set to SSL=Yes!

Also, all of my App in a minute one left site cannot be open:

Documents are Working
The update was on Ubuntu 20.04 with apt update & upgrate und the Files xwiki.cfg, and xwiki-tomcat are the new ones from installation and after that i insert thinks like ldap Admin User/passwort thinks

How can I fix that 2 Problems?

Many thanks in advance

GM everybody,
is there nobody how can help?

Many thanks @all

Hello @all,
is there nothing what I can do to fix the problem?

Many thanks

Hello @all,
update to 13.10.7 and still have the same problem:

  1. Access to sub wiki called only http URI instant of https.
  2. Access to App within minute over Sidebar are not possible.

Is there anything what i can change to solve the problem?

Many thanks in advanced

it would be really great if there would be some support for this.
Unfortunately it is not even possible to create a new SubWiki after the upgrade, because it is impossible to install a flavor.
Xwiki can only be kept up to date if the update/upgrade procedures work and you get help with this.

I therefore ask again for help!

Thanks in advance

Hello @all,

I was able to fix the problem with opening apps within a minute thanks to vishrtd’s post from August 2021:
Edit xwiki.cfg and uncomment following two lines:


But now there is still the problem that a sub Xwiki cannot be opened directly from the main Xwiki, because here the URL is tried to open in http instead of https.
How can this problem be fixed?

Many thnks

Maybe check your first request to XWiki and ensures it’s done with HTTPS and not HTTP. See also


Perfect vmassol! You saved my day!! :slight_smile:
Change of property in xwiki.cfg solved this problem


Many many thanks!