APT Update GPG Error in new installation

Hello all,

This is close to but not the same as the same topic “APT Configuration GPG Error in new installation”
I’m running into the same error but in this case the error is at the end of step 2. This is my first attempt to work with XWiki, and don’t have too much experience with Linux as well.

My configuration is:

  • VM Workstation 15.5
  • Ubuntu 20.04 / Debian 11

Step 2 starts out okay
# wget -q "https://maven.xwiki.org/public.gpg" -O- | sudo apt-key add -
OK
# wget "https://maven.xwiki.org/stable/xwiki-stable.list" -P /etc/apt/sources.list.d/
→ gets through 100%

I have the problem at this next one
# apt-get update

W: GPG error: https://maven.xwiki.org stable/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F716794B93CC9C13
E: The repository 'https://maven.xwiki.org stable/ Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I found how to manually pull the key and tried that
# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F716794B93CC9C13

Executing: /tmp/apt-key-gpghome.SAtuexHxJk/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys F716794B93CC9C13
gpg: key F716794B93CC9C13: "XWiki Dev Team <committers@xwiki.org>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1

This looks like the key does exist and is available? From what I’ve seen this would read ‘imported: 1’
Checking the ‘Trusted Software provider’ GUI, it shows
F716794B93CC9C13 2020-11-04
XWiki Dev Team <committers@xwiki.org>

I tried all of this on Raspberry Pi 4 8GB with exact same results. I thought the VM may have impacted things but not think otherwise.

Without updating the next step of installing tomcat fails.

Any help getting XWiki running would be greatly appreciated.
Thank you

That’s not what is documented on https://www.xwiki.org/xwiki/bin/view/Documentation/AdminGuide/Installation/InstallationViaAPT/. What you are using is older instructions, but the current standard xwiki-stable.list file is configured to expect to find the key in a specific location (new apt recommendations).

Thank you tmortagne, that got me up and running!