Best practice for tests regarding the public keyword

Hi devs,

JUnit5 doesn’t need the “public” keyword anymore, and Sonarlint considers it a best practice to not have it. Makes sense to me. We’re already doing this in most places for test methods. This proposal is about making sure we’re all ok so that we can write it on dev.xwiki.org, and to also remove it at the class level.

Thanks
-Vincent

+1

Thanks,
Marius

+1

+1

Thanks,
Alex

+1