Blog upgrade from 8.4.6 to 9.2 version doesn't work


#1

Hello,

I’m upgrading xwiki 8.4.6 to 9.11.2 but blog upgrade doesn’t work…
It doesn’t work neither from extension updater.
The updater displayed:

Failed to install optional dependency [org.xwiki.platform:xwiki-platform-blog-api-[9.11.2]] with error: ExtensionNotFoundException: Could not find extension dependency [org.xwiki.platform:xwiki-platform-blog-api-[9.11.2]]

Do you think it is a temporary repository issue?

Thxs.

Pascal BASTIEN


#2

Hum maybe this issue: https://jira.xwiki.org/browse/XCOMMONS-1325 (Extension Manager canot find dependencies coming from a repository defined in a pom)…


#3

No this is https://jira.xwiki.org/browse/XWIKI-14699 (and the root cause is https://jira.xwiki.org/browse/BLOG-99).

In short the blog id changed so auto upgrade does not find new compatible version, you will have to go to EM and install the new version (which will replace the old one).


#4

Thxs. Sorry I didn’t check well jira before to post :confused:

I will give a try.


#5

Actually, upgrade blog extension 8.4.6 to 9.7 working well in EM…