Cannot enable/disable user notification filters

Hi XWiki Community,

I have faced the following behavior. when trying to disable/enable user notification filters, I get “failed to save filter preferences”:

for some reason it is trying to post to malformed URL. it simply lacks domain part. I use XWiki 10.2 docker mysql tomcat. Upgraded to 11 - same thing. Is it a bug ?

Is anyone able to use this functionality ?
It’s hard to imagine it is something related to my installation…

Do you have some specific setup for your instance (compared to the default)? We would need that to reproduce the issue.

It’s docker XWiki instance behind NGINX with SSL.
But I’ve tried to access the same setting directly on container’s tomcat… still the same issue…
Database was sequentially updated from version 8 to 11.
Will check with empty DB on clean instance a bit later…

Hm… Checked on clean install - works fine…
Any ideas on what to check will be much appreciated.

Managed to reproduce!
Added the following in wiki.cfg of the brand new clean installation:


Looks like a bug

upd: the culprit is xwiki.home
unset it on the prod. instance and I am able to disable/enable filter now…

Would be great if you could raise a jira issue at