Can't upload attachments/images in 14.10.8


after updating my Xwiki from 13.10.3 to 14.10.8, i can’t upload attachments anymore. I’ll get this error:
And in the browser-dev-tools i’ll see an “net::ERR_INVALID_RESPONSE” at ?resubmit=…

But nothing else - I don’t see anything in the tomcat logs.

And if i try to paste an image in CKEditor, I’ll get both success and error, but the image isn’t there:

But the strange thing there is: My Xwiki is german-based. But if I’ll add an english translation of the page, i can paste attachments successfully. Changing back to german, the error is back again.

Attachment size limit has been checked (add resetted to 10MB, but even 9KB-attachments won’t work). File system has a lot of space left.

What else should I check?


Edit: after some additional tries of uploading using the attachments-page, the first CSRFToken-message appears: " WARN o.x.c.i.DefaultCSRFToken - CSRFToken: Secret token verification failed, token: “null”, stored token: …" - they weren’t coming before.
But still no message using CKEditor.

Hello @schnutz,

I’ve tried to reproduce the described issue, on a multi-lingual wiki with English + German (I also tried on a sub-wiki with the same settings).
The upload, using the “Anhänge” pane at the bottom of the page seems to be working successfully both on German and English pages.

Out of curiosity, did you try to clean your browser cache?

Also, if you can give me more information regarding the failing request, it could help narrow down the source of the issue.



browser cache has been cleared (to be sure just now once again), but still no luck,
I’ve disabled CSRF and it seems to work better, re-enabled it and the error comes again.

We have Short URLs in place, so maybe it’s like Loading... . I’ll try to do follow the workarounds there (but for this I’ll need our tech-team), so I’ll come back with my findings i think next week.

I confirm that this looks like it’s what’s causing the problems you’re having.

So it probably means that you’ve upgraded the version of Tomcat used. See Short URLs (

No, it was already tomcat 9 before, it’s from the standard-docker-image
before: xwiki:13.10.3-mysql-tomcat
now: xwiki:14.10.8-mysql-tomcat

I just checked the tomcat-logs on prod (v13.10.3): Server version name: Apache Tomcat/9.0.58

The error now is on the test-system, we planned to update our prod system next week, but we postponed this now. But now i can access both systems and can compare several settings (for some i need the tech-team).

ok - there were several issues: Our tech-team always used the “old” web.xml, xwiki.cfg and without merging the new entries - perhaps there were also some issues. Now with 14.10.10 (in the meantime) we fixed this.

But uploading with activated shortUrls were still not working. We also added the workaround for /upload/* in the web.xml - same error.
But then - with the “new” corrected config-files, i saw in the browser-dev-tools, that uploading an image in CKEditor called /get (I’m sure it was something else before) :

so i added “/get” to web.xml too to the action-servlet, and now it’s working:



Is this ok or is it very bad? But it must be this, i removed it again for testing and it didn’t work…

I can’t tell about the GET action but there was an issue with the POST one: in the workaround described in the short URLs documentation, a step was missing, now added.