Code snippet issue


I am trying to use code snippet: insert -> macro -> code
(xwiki 12.6.1 + CKeditor)

in the content field I am typing:

<?m2e execute onConfiguration,onIncremental?>

after submit, the typed text is gone
I tried with language property: [empty], none, xml. All end with same result.

How can I escape this text in code snippet?

extra info:
when editing source, after toggling it back from source view, it does show correctly, but after save & view it disappears.

Hi, I’ve just tried (on 12.7SNAPSHOT but it shouldn’t matter), and it worked for me.

Screenshot 2020-08-23 at 18.14.09

Hi @mq2195,

do you keep reproducing the bug? Which browser do you use?

Sounds like a problem between the request and the server when saving, can you try to reproduce but by clicking on “Save” (not save & view) and check in your browser’s network tab (in developer tools) the request sent a the response from the server. Could be a configuration problem on the server.
Also check the logs of your server to see if it provides a stacktrace.

See .