Confluence Migrator, its dependencies, questions about migration tests


I have installed XWiki on 2 test servers:
one with 14.10 (now 14.10.11) as for the recommandation from Jean-Sébastien Dennebouy, and one with the XWiki 15.3 edition, because I have been told this is the Edition which will get the updated Realtime Collaborative Edition feature when your team will have finished integrating Cryptpad at the end of the year (which you told me can do realtime editing while used by several people in collaborative mode).

Now our goal it to achieve success in a test import from Confluence.

The context : we have a 7.4.17 version of Confluence on premice. We will ultimately have several dozens spaces to import.

I am aiming to succeed with the import of 1 space now (half a Gigabyte), in the context of the current tests I am performing (several features will later need testing, this one being 1 of the 2 major ones we need to get in the future production stanza).

Therefore I need to test a Confluence space import and make it a success, and I have a question about the Nested Pages Migrator Application and the Pro Macros which come with Confluence migrator, because the first time I tried, in the 15.3 edition, it failed at stage 5* (or maybe even at stage 4 although step 4 had seemed to work).

  • the UI (for Nested Pages) displays “0.9.1 - Version 0.7.6 is installed as dependancy” - the UI for Pro Macros : “1.8.1 - Version 1.6.1 is installed as dependancy”.

My question is : is it recommanded to update, by clicking on “Continue”, or is it recommanded to not update?

For now I have updated these two extensions. I have also noticed warning messages. Are they harmless?

In the 14.10.11 install:

Nested Migrator Application extension, from 0.7.6 to 0.9.1.
“Can’t find any existing component with class [org.xwiki.contrib.nestedpagesmigrator.internal.serializer.MigrationPlanDeserializer]. Ignoring it.”

Pro Macros
“Can’t find any existing component with class [com.xwiki.macros.userlist.internal.macro.GroupReferenceListConverter]. Ignoring it.”

In the previous Confluence import test (which failed on stage 5) on the 15.3 install I had updated the 2 packages. Also, yesterday I noticed a detail in the file /etc/default/tomcat9 in the server:

# The home directory of the Java development kit (JDK). You need at least
# JDK version 8. If JAVA_HOME is not set, some common directories for
# OpenJDK and the Oracle JDK are tried.

Is it ok to leave it as is? Or is it better to provide the right path, which here is

I planned to test this part, and I guess it doesn’t hurt to ask about it?

failed at stage 5* in the 15.3 XWiki Edition installed : if you wonder how it went:

I had followed each step carefully, exported a space from Confluence, the archive was a little less than 500MB large. Once imported I could make it through the 4 first steps, then it stalled at step 5 “Compute plan”.

I understand it can take long, but I don’t think it should take several hours to actually move on and do something, especially if it does not end with doing something.

What I had got:

“The plan is being computed and it could take some time. Please wait… ” 40 minutes later, still nothing had happened, no log shown either.

I tried to go back to the previous page and mark “true” to " Stop when document save fail Indicate if an exception should be thrown if a document save fail ", then I had this message:

“Current conversion
Error has been found during the conversion !

Job log

    Starting job of type [filter.converter] with identifier [filter/converter/confluence+xml/xwiki+instance]
    /var/cache/tomcat9/Catalina/localhost/xwiki/xwiki-temp/confluencexml15965134332037731381/entities.xml (No such file or directory) ”

In the directory pointed by the error message, there was only a directory with the name “tree” which was empty.

Then I clicked “Finish”. Next the stage two showed a new message:

“To minimize migration duration, we recommend to ensure that the Solr queue is empty before starting the migration,
check the Solr queue size on the Wiki Administration, [Solr Search Section](http://[our url]:8080/xwiki/bin/admin/XWiki/XWikiPreferences?editor=globaladmin&section=Search) (optional)”

I tried resetting the migration process.

I could not proceed until the end before I was on leave.

When I resumed the work on this project, we reinstalled a working snapshot of the 15.x. edition.

Thanks for your work, and thanks for providing me with some insights!

at the end of Step 1 of the Confluence migration tool on the 14.10.11 install, I met with:
Deactivate notifications on your [own profile]( ("never" for automatic page watching, disable page notifications)
But this does not exist in the profile.

On the XWiki blog: Confluence to XWiki migration guide: from export to customization - XWiki

but on the install, there is no Notifications menu in the Settings list.

However, once I had deactivated the notifications pointed below that part,

    Deactivate Notifications listeners from XWiki.ListenerAdmin page on main wiki:
        Document Moved Listener (important for large spaces)
        Automatic Watch Mode Listener (important for large spaces)
        LiveNotificationEmailListener (important for large spaces)

and refreshed the page, the request to deactivate notifications on my own profile disappeared.

Just wanted to report it.

Hello. I am also having a problem migrating from Confluence to XWiki. Almost all of the spaces have been migrated without any problems.
But one of the spaces (the largest of all, 3.5GB and 3500 pages) I imported using Filter Streams Converter Application 15.5.4, then to restore the page hierarchy I use Nested Pages Migrator Application 0.10.1.
I click on the “Compute plan” button and then I see
Then I click on the “Execute plan” button and immediately “The plan has been executed!”, nothing appears in the LOGS section and all the buttons are inactive.
This problem affects only one space. I have not found similar problems with other forum users.

I’m using the XWiki 15.5.4 Docker version.

@Shekel The thread you are answering does not refer to the same issue as yours.

It was about some notifications which were not relevant, plus we don’t use the 14 branch anymore for our ongoing project.

I have met with a nesting issue once. Are you using the manual method for importing spaces?

Can you logout and login again, to check in the navigation side if your space has indeed been imported and nested? Otherwise you might want to delete it completely and retry.
Here I have Filter Streams Converter Application 15.10.4 , no 15.5.4, does 15.5* exist?

Thanks, I’ve already tried logout/login, docker restart, uninstall and install again Nested Pages Migration, deleted and re-imported the space, but no luck.
I have the problem with only one space, the other 42 spaces did not have this problem. Because there are no entries in the logs, I can’t find the cause.

You might need to open a topic of your own, and seek for ways to activate logs/debug, if you haven’t yet.