Diagram App not loading

Hello,

I recently tried out the Diagram App and then upgraded to Pro Version. After my trial expired, I fully uninstalled the Extension via Extension Manager and then reinstalled the standard Version.

Now when I try to create a new Diagram the page gets stuck on loading screen (the spinner icon just goes on endlessly). I tested on different Browsers with the same result. Any ideas on what to do?

I’d also like to add that we recently set up SSL for our wiki, maybe thats connected.

Maybe you need to clear your browser’s cache. You could also check if there is a JavaScript error logged in the JavaScript console from the browser’s developer tools.

Clearing the browsers cache didn’t work.

I get following messages in the developer console when trying to create a diagram:
1

I am not sure but does this mean that the Spinner image I am getting is still not in https and that is the reason it is not working?

This is how the error messages look when I uncomment xwiki.url.protocol in xwiki.cfg (I didn’t setup SSL and am currently not sure if I need to have this uncommented or not):

2

I think I am experiencing the same problem as described in this thread:

https://forum.xwiki.org/t/spinner-gif-requested-over-http-instead-of-https/4167/6

It says here that the problem has already been fixed though (our wiki is currently on version 11.10.2-1).

The issue is that you haven’t actually uninstalled the Pro version completely. Both the Pro version and the free version share some dependencies: draw.io and mxgraph-client. The Pro version requires some newer version of these dependencies. When you uninstalled the Pro version these dependencies have remained installed. The problem is that the code of the free version hasn’t been updated to work with the newer version of draw.io and mxgraph-client, so it fails.

To fix this you need to downgrade or uninstall the newer versions of draw.io and mxgraph-client, and then re-install the free version of the Diagram application.

Thanks for the reply.
I tried uninstalling everything. In extension manager I clicked on dependencies and uninstalled draw.io Webjar and mxgraph Editor Webjar. I still get the mixed content warning though.

I then re-installed the normal diagram app, but the problem still persists.

We’ve faced the same issue last week. What we did was to remove the following:

├── drawio
│   └── 12%2E3%2E3
│       ├── org%2Exwiki%2Econtrib%3Adraw%2Eio-12%2E3%2E3.jar
│       └── org%2Exwiki%2Econtrib%3Adraw%2Eio-12%2E3%2E3.xed
├── mxgraphclient
│   └── 4%2E0%2E6_12%2E3%2E3
│       ├── org%2Exwiki%2Econtrib%3Amxgraph-client-4%2E0%2E6_12%2E3%2E3.jar
│       └── org%2Exwiki%2Econtrib%3Amxgraph-client-4%2E0%2E6_12%2E3%2E3.xed
└── mxgrapheditor
    └── 4%2E0%2E6_12%2E3%2E3
        ├── org%2Exwiki%2Econtrib%3Amxgraph-editor-4%2E0%2E6_12%2E3%2E3.jar
        └── org%2Exwiki%2Econtrib%3Amxgraph-editor-4%2E0%2E6_12%2E3%2E3.xed

from the extension/repository/ directory. Then restart XWiki and it should be back to normal.

To solve this issue we’ve also tried uninstalling these libraries manually, but it didn’t help either, as the files have not been removed from the repository, hence as I understand, they were always loaded even though the plugins have not been installed.

1 Like

I actually can’t find these files. The /etc/xwiki/extensions directory is empty. Couldn’t find them anywhere else in the XWiki directories

@kaydee64 , if Xwiki still doesn’t work, then these files have to be somewhere on your host. We’re having XWiki in containerized environment so cannot help regarding directory structure as they probably differ.

My fault I found them and deleted all of them. Restarted the server and Diagram app works now. Thanks a lot blelump!

The spinner http/https issue is still there, but I guess I’ll move that to another thread.