Docker Upgrade from 10.11.3 to 10.11.4 doesn't move the pages

I am in the last step of upgrading XWIKI but the pages migration doesn’t seem to work, so I cannot see all my structure here in this tree:


Are they hidden in a submenu? I had a structure like:


what page migration? What are you referring to?

So I was running 10.11.3 , stopped the tomcat container, start a new one with 10.11.4, went through the corresponding upgrade of the addons, and at the last step is where I assume the content (pages) are migrated. But I cannot see mines in the tree. And yesterday I tried to “Continue” and I ended up with loosing the Navigation menu with all the pages I had.

P.S. It was a testing instance.


Because there’s no concept of migrating user pages :slight_smile:

Only thing that is done is merge pages that are contributed by extensions in case the new XWiki version has updated dependencies bringing new versions of these pages. This is what the tree is showing, see

As is stated it is “The last step display all changes brought to the wiki.”. There’s no change to your pages so they’re not listed.

I see…and do you have any idea why the pages are gone after the upgrade?did I missed something?


The small house at the top doesn’t show anything neither.

Probably because you have some browser caching acting up. Clear you browser cache. BTW this has been fixed but you’re using some oldish versions. You should really always upgrade to the latest version. Latest LTS is 10.11.8 right now.

You are totally right! Now with incognito window I see.

Yesterday I tried to upgrade to 10.11.8 and I got this caching issue, so I decided today to move only one version up. But yes, I will upgrade straight to latest.

Thanks a lot!