Enable ckeditor access with ssl nginx proxy

Hi there, I’ve followed the ‘secure’ directions using Nginx as a reverse-proxy for http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationTomcat#Hhttps28secure29

My 9.7 xwiki install is now up and accessible via https , however, I’ve now noticed that when editing pages, the ckeditor does not load at all. I need to manually set the browser (firefox and chrome) to all mixed content or ‘unsafe scripts’ in order for the wysiwyg editor to appear.

Is there a step I’m missing or a work-around for this issue ?

Never mind; just realized what was happening. I had previously tested out extending the ckeditor and was using a png file stored on a different server (http-only) in order to skin a button.

Once I removed that line from Advanced Configuration on the Administration: WYSIWYG Editor page, ckeditor reappeared automatically without touching any browser-specific, mixed content blocking settings.