Failed to use offline flavor with docker

Hello,

I’m currently trying to install xwiki offline in a docker environment.

It works and i can access to the xwiki main page but for the moment i cant use the standard flavor. My flavor list is empty in my distribution wizard.

My method was to start the docker container, enter in it, unzip the xip package and restart the docker. I tried more than 10 times and each time i had an empty flavors list.

i use the same version of xwiki war and xip.

I put the capture of the content of my permanent directory.
unzip

The instruction at https://www.xwiki.org/xwiki/bin/view/Documentation/AdminGuide/Installation/#HInstallingwithoutinternetconnection says to unzip in the permanent directory. That directory is local on your host and you map it when you start the docker image. So I’m not sure sure why you need to enter the container and unzip there. That part doesn’t look right to me.

I have to enter in the container because, the permanent directory is not created before i start the container (and the tomcat). So i cant put this instruction before the catalina start. I did it by scripting in the docker entry point but its the same result in all case.

I did :

  • Catalina.sh start
  • unzip in permanent directory
  • Catalina.sh stop
  • Cataline.sh start

And the result is the same

You’re the one providing the permanent directory :slight_smile: It’s just that XWiki will create anything it needs there if it doesn’t exist.

yes it shouldn’t change. Now I don’t see why docker would lead to a different result for XIP install than without docker. I’ll have to try it when I get some time.

Ok thank you for your replies. I dont understand too why there is a difference.