I can't see the distribution Wizard when i'm update


I try to update xwiki (12.4 → 13.6) but when i replace the file “.war” and i update the wiki. There is no changement and the distribution wizard doesn’t appear. The version is the same (12.4), i don’t know what i’m doing wrong…

Can you help me, please ?

Thank you,

Good day !

Maybe see Distribution Wizard (XWiki.org)

Okay, thanks !

I change the file .war (13.6) and i delete the file “statuts.xml” but it doesn’t change…

When the last .war (12.4) is in the configuration and when i delete the file status.xml, the distribution appear.

Why when i change the .war (on 13.6), the distribution doesn’t appear ?

Did you log as admin?


I really don’t understand ^^’

I’m going to try to change the version for update.

Just for the information i work on a debian 10

Hard to tell if you don’t give some information on how exactly you did the upgrade.

  1. I’m connect to my debian (root)
  2. i replace the .war (12.4) by an another .war (13.6)
  3. i make an “apt-get xwiki-common 13.6” (I try with and without this step)
  4. i delete the “status.xml”
  5. i restart tomcat servcie

Those steps don’t make sense to me. Are you using the debian packages or the WAR ?

I tried in first time to change the file .war and nothing change.

So after, I tied to make an apt-get xwiki and it doesn’t change too.

Those are two totally different things, and you cannot just try them randomly. You need to use the right upgrade depending on how the previous version of XWiki was installed, see Upgrading (XWiki.org).

Yeah I know,

I tried to make the upgrade with debian package :

  1. apt-get update
  2. apt-get upgrade
  3. apt-get install xwiki-tomcat9-mysql

But nothing Change, i make the right steps ?

It’s for that I tried to replace the .war file :confused:

I tried xwiki-common 14.4, but it’s the same result. Xwiki start to the home page and it’s the last version

I make this command :confused:

After i make an apt-get update and they tell me that no KEY_PUBKEY.

Okay now i’m block when xwiki try to write in the BDD.

java.sql.SQLException: Cannot create PoolableConnectionFactory (Access denied for user 'xwiki'@'localhost' (using password: YES))

And the user “xwiki” have the same rights taht the user “root”…

Caused by: org.hibernate.HibernateException: Could not create a DBCP pool. There is an error in the Hibernate configuration file, please review it.

And i have this too… I really despair. If you have any idea for that, really thanks for advice.