Installed XWiki Standard flavor offline in docker environment meets a strange problem

Recently, I get a problem when I try to install xwiki in docker environment offline,I’ve try to search similar problem on google or some other search engines and try many ways to get through but not solved.
The problem is ,after I followed the guide installing flavor offline, I open localhost:8080,the xwiki looks good,but its WYSISWYG editor can’t load, its user right pages also recommending “the environment prevents from loading data”.
Here are my operations:

1.system and docker version

kylin is a centos based system)

Linux version 4.19.90-23.8.v2101.ky10.x86_64 (KYLINSOFT@localhost.localdomain) (gcc version 7.3.0 (GCC)) #1 SMP Mon May 17 17:08:34 CST 2021

Version: 24.0.6
API version: 1.43 (minimum version 1.12)
Go version: go1.20.7
Git commit: 1a79695
Built: Mon Sep 4 12:32:17 2023
OS/Arch: linux/amd64
Experimental: false
Version: v1.7.3
GitCommit: 7880925980b188f4c97b462f709d0db8e8962aff
Version: 1.1.9
GitCommit: v1.1.9-0-gccaecfc
Version: 0.19.0
GitCommit: de40ad0

I install same version of docker on both system.

2.xwiki images and mysql images

xwiki image comes from “docker pull xwiki”
mysql image comes from>xwiki-docker->docker-compose up,and build from container,version is 5.7

3.xwiki and mysql running
first I create docker network,

docker network create xwiki-nw

then I run mysql,using

docker run --net xwiki-nw --name xwiki-mysql-db -v ./mysql/xwiki.cnf:/etc/mysql/cnf.d/xwiki.cnf -v mysql-data:/var/lib/mysql -v ./mysql/init.sql:/docker-entrypoint-initdb.d/init.sql -e MYSQL_ROOT_PASSWORD=xwiki -e MYSQL_USER=xwiki -e MYSQL_PASSWORD=xwiki -e MYSQL_DATABASE=xwiki -d mysql-success:1.0 --character-set-server=utf8 --collation-server=utf8_bin --explicit-defaults-for-timestamp=1


default-character-set = utf8

character-set-server = utf8
collation-server = utf8_bin
explicit_defaults_for_timestamp = 1

default-character-set = utf8


grant all privileges on . to xwiki@’%’

after mysql established, I run xwiki

docker run --net=xwiki-nw --name xwiki-mysql-tomcat-web1 -p 8080:8080 -v xwiki-data:/usr/local/xwiki1 -e DB_USER=xwiki -e DB_DATABASE=xwiki -e DB_PASSWORD=xwiki -e DB_HOST=xwiki-mysql-db -d xwiki:latest

then I start to install flavor offline,standard flavor 15.8 xip comes from nexus.
using command

docker cp xwiki… containerID:/usr/local/xwiki/data/extension/repository
docker exec -it containerID bash
cd /usr/local/xwiki/data/extension/repository && unzip -o xwiki…
docker restart

then I open localhost:8080 to start install flavor on web page.

honestly speaking , I’ve tried to install flavor using both registered “root” account and “superadmin” account(edit xwiki.cfg) since I read some articles say that flavor installation without superadmin may caused strange problems,somehow both come into same result.

edit xwiki.cfg

docker exec -it conainerID bash
cd /usr/local/xwiki/data && rm -rf xwiki.cfg && exit
docker cp xwiki.cfg containerID:/usr/local/xwiki/data
docker restart containerID

after a period of time, flavor installed finished
then the problem come out
1.WYSISWYG editor seems lack of something

2.administrator page can’t load data

the second problem is more important, since I can still use simple text editor.

can anybody tells me how to solve this problem?
I install xwiki online on docker, and everything runs well
I’ve copy successful /usr/local/xwiki /usr/local/tomcat dir into failed one and restart docker, but nothing changed.
I’ve copy successful docker volumes to failed one as well,but nothing changed
once I packed success one into new image and load it in offline server, finally get an empty wiki seems nothing happens at all

I’ve been tracked into this thing for nearly one month