LDAP login issues

Hello Team,

I am trying to get the LDAP authentication working on our new instance of wiki but failing badly.
These are the steps i followed so far:

  1. I have installed the latest version on a docker image.
  2. I have installed the LDAP Authenticator extension,
  3. I have updated the config as per LDAP Authenticator (XWiki.org)
  4. I have also updated LDAP info from Global administration

The main issue is i get this error when i try to login via LDAP:

I have enabled logging on logback.xml and was able to look into the log but couldnt understand what might be causing the issue:
Log.txt (44.6 KB)

I have uploaded the log to the post.

Can one of the experts here kindly assist me please.

That will be a great help.

Hi @Ausviking ,

Something is wrong in your configuration.

java.lang.IllegalArgumentException: can't parse argument number: uday.kopparapu
at org.xwiki.contrib.ldap.XWikiLDAPConfig.getLDAPBindDN(XWikiLDAPConfig.java:792)
Caused by: java.lang.NumberFormatException: For input string: "uday.kopparapu"

It is not clear if " updated the config as per LDAP Authenticator (XWiki.org)" is correct. Could you provide more details about your config?

Hello @acotiuga ,

I have attached the xwiki.cfg here or would you like me to just copy and paste the specifics here?
Log1.txt (12.1 KB)

Thanks heaps for your help mate. :slight_smile:

Hi @Ausviking,

it looks like the “.” in xwiki.authentication.ldap.bind_DN value in xwiki.cfg causes this error. Have you tried putting quotes around the value?

I tried it and it didnt work unfortunately :frowning: :sob:

Are you sure the xwiki.cfg you shared is the one in use ?

The error suggests you have a configuration with the LDAP bin DN containing {uday.kopparapu} (and the format expect only number inside {}). Maybe you used the LDAP Application and tried something like cn={uday.kopparapu},ou=Users,dc=jumpcloud,dc=com from the wiki and never reset it (what’s on the wiki has priority over what’s in xwiki.cfg file).

Hello All,

with @acotiuga 's assistance, i was able to resolve this issue.
Thank you everyone for your help.