Logo image file upload failing

I’m on freshly-installed xwiki debian 15.6 instance running Ubuntu 20 with tomcat9 and mariadb 10.3.38. I’m just trying to upload a different logo png file, but I keep getting an “Attachment upload error” message and am not sure what is causing the issue (other than a ‘bad request’):


Hello @inoida,

I tried to reproduce but it seems to be working ok on my end.

Could you check the failing POST Http request on the network tab and copy the response?
Also, if you have access to server-side logs, it could be interesting to ckeck if something interesting is displayed there.

Here’s the response:

    "uploaded": 0,
    "error": {
        "number": 400,
        "message": "Error when uploading the file: it might exceed the configured maximum upload size."

I thought initially the issue was just with my nginx conf, but I definitely had client_max_body_size 0; in my nginx site config, and removing ngnix out of picture and just trying things directly via tomcat9 I still get the error above.

Where / how would I configure the maximum upload size mentioned in the response message?