Menu Application Issues and Visual edits

Hi all. Will jump straight into the issues:

  1. Since I began using the menu app, there are instances where it switches from its normal state as a vertical menu bar, to its horizontal list state(please see pictures below. To fix this I usually have to clear my cache and restart the xwiki servlet or Tomcat(I am using WAR version).

Screenshot (7)

To this

Screenshot (8)

I have also tried using the menu macro to try and circumvent this ({{menu id="…" type="…"}}…content here…
{{/menu}}) but sadly that hasn’t worked either.( the macro also gives an odd look where its seems to end before the edge of the screen. I assume that’s a type issue as fixed width doesn’t seem to solve it for me)

  1. I am trying to create a clean homepage but I want to remove the content menu sort of like what is done within most of the xwiki site pages. I have searched but cant seem to find how to edit this out. see image below for what it is I would like to remove.:

removing tag and home page

Any help as always wil be greatly appreited, and if this post contains too much I would gladly edit and create a separate post for the issues listed here. I just figured them being within more cosmetic edit, it would be appropriate for them to be listed together.


Restarting XWiki shouldn’t have any effect on this. You need to clear your browser cache only once. If you find that it happens again, my guess is that you have several wikis with different versions of XWiki and that’s why your browser have the wrong version in its cache from time to time. Could that be it?

By “xwiki site pages” I guess you mean However we haven’t touched that on (for ex: Do you have a link?

So you have 2 ways (see How to Remove (view source, children) - #6 by Pbas):

  • Hiding the title and menu with CSS, using a SSX
  • Modify the template vm: contentheader.vm by creating a custom skin or overriding the template vm on the filesystem

How will users be able to edit content if you hide the menu? (just curious :))

Sadly that is not the case, I am running on xwiki 9.5.1 with one sub wiki based on a template of the main wiki, so they are nearly identical. I noticed it tends to happen more often when I perform a page edit or menu application edit. The moment I refresh a page that has no admin privileges , it tends to become like that. But the admin page I am working on is fine.

With regards to the menu macro, what is the type that allows it to utilize the full screen? I feel this might help mitigate the issue if it persists with the basic menu app.

I meant the homepage of :sweat_smile: . I am perfectly fine with the way it is on the other pages. I was hoping for a way to hide it if the users aren’t under admin, that way it is still editable. But standard users simply get no content menu (if the only solution is hard coding for everyone then its fine).

Ok then you should go with the skin override for contentheader.vm and use the #if ($hasAdmin) construct.

With regards to the menu issue, I discovered(not sure if its the sole reason, but it seems to work) that if you have a sub wiki, when the sub wiki is loaded and the user viewing the main wiki does not have similar viewing permissions(particularly the script permission), then the menu defaults to its vertical form/breaks. By changing the permission in the sub wiki for un registered users to have the script permission, the menu seems to behave across the board. I have tested this multiple times and that seems to be the issue.
Thanks for all the help, hope this information helps others.

Hello Vincent, apologies for bringing this topic back up, it seems to have become a rather important edit to be made. I understand what the solution is, but its going about it thats giving me trouble. Could you provide me with links to the information that may help, also, in order to perform skin overrides, does this remove the current skin I am using? looking at the code you gave me, it looks like Velocity Syntax, so does that mean it can be done within the wiki itself. I am trying to know where I can start from to edit the VM without basically breaking everything.


I encounter the same problem. Did you ever solved it ?
The “allow Script for unregistered” work around does not work for me :frowning: