Need help with SOLR Search Engine

Hello everyone.

I’ve migrated to a newer XWIKI and it’s been working very well since the past month. Unfortunately, the search function doesnt work properly. Users have been complaining about not finding documents while in they could in the older version. I still have the old XWIKI running and could test : They are right, the older instance which use lucene is able to find 4 documents or pages with the name “OLABSO” :

But with the new shiny XWIKI and SOLR search Engine, it doesnt find anything (despite the fact that the data is correctly imported into the new instance).

It seems SOLR works when asked for the exact name page, if you look for everything else it wont find.

Does anyone can help me with this ? I’m sure I’m missing some settings somewhere.

Thanks in advance.

I don’t know much about your problem, but where exactly is this name “OLABSO” found? in an object? in the content?

Depending on your usage, you might want to better configure the search fields, it is documented here

Thanks for your quick answer.
OLABSO is found in the content of 3 pages and in the content of 1 attached docx file. Lucene found this 4 occurences, none for SOLR.
Thanks I will dig into that !


Could be we get a screenshot of this word in context please?
Is OLABSO a fully formed word, or part of a word?
What happens is you create a new page with the text pasted in?

Hi Ben, sure :
Content of one of the 3 said page :

Content of the .docx attached file also containing the word :

Just created this page :

Still no luck.

Note that I took OLABSO as an example, it’ the same for any other keyword.
When I changed the search engine by “Database”, I was able to get the 3 documents containing the word but NOT the .docx attached file.

Sorry if I posted 3 times in a row but as a new user I’m not able to post more than 1 picture in a single post.


See . Can you show us the “Debug Information” you get for the “OLABSO” search? What is the default language set in the Wiki Administration? Could it be that you set the default language to fr_FR? See .

Hi, I’ve done it :

Debug Information

Query Parser


Parsed Query

+((filename:olabso)^0.4 | (attauthor_display:olabso)^0.016 | ((doccontent__:olabso | doccontent_fr_FR:OLABSO)~0.1)^2.0 | (author_display:olabso)^0.08 | (name:olabso)^10.0 | (spaces:olabso)^0.016 | (creator_display:olabso)^0.08 | ((comment__:olabso | comment_fr_FR:OLABSO)~0.1)^0.016 | ((title__:olabso | title_fr_FR:OLABSO)~0.1)^10.0 | ((objcontent__:olabso | objcontent_fr_FR:OLABSO)~0.1)^0.4 | ((doccontentraw__:olabso | doccontentraw_fr_FR:OLABSO)~0.1)^0.4 | ((attcontent_fr_FR:OLABSO | attcontent__:olabso)~0.1)^0.4)~0.1 ()

Filter Queries

  • {!tag=hidden}hidden:(false)
  • {!tag=type}type:(“DOCUMENT”)
  • {!tag=locale}locale:(“fr” OR “”)

Processing Time

  • time: 7.0
  • prepare:
    • time: 1.0
    • query: {time=1.0}
    • facet: {time=0.0}
    • facet_module: {time=0.0}
    • mlt: {time=0.0}
    • highlight: {time=0.0}
    • stats: {time=0.0}
    • expand: {time=0.0}
    • terms: {time=0.0}
    • debug: {time=0.0}
  • process:
    • time: 5.0
    • query: {time=0.0}
    • facet: {time=2.0}
    • facet_module: {time=0.0}
    • mlt: {time=0.0}
    • highlight: {time=1.0}
    • stats: {time=0.0}
    • expand: {time=0.0}
    • terms: {time=0.0}
    • debug: {time=0.0}

Indeed the default language for my Xwiki is set to french :


I’ve just redd the Jira post. Should I change some language settings to make it work ?

Thanks a lot for your help.

You should select “Francais” (the first one listed) instead of “Francais (France)”. Then you need to update the default language for the pages you already created. You can do that by editing each page in wiki edit mode and using the panel on the right. If there are too many pages then you’ll need a script.