New guy looking for first time installation help

Hi! I’m new to using XWiki, and I’m running into what’s probably new-guy problems getting the environment up and running for the first time.

I’m running on AWS EC2 instances, and tried two different approaches to getting XWiki running:

Manual, WAR-file installation on Amazon Linux 2
Automated deployment on Ubuntu 18

In both cases, the installation process seems to get hung up when I start Tomcat and try to connect via http://localhost:8080/xwiki. I get a message that XWiki is initializing (12%)… and it never seems to go beyond that point.

Probably I’m missing something obvious, but all my hunting through the installation documents hasn’t put me on the scent yet.

My ideal architecture is multiple instances of XWiki connecting to a remote back-end MySQL DB, but as it is I’m struggling to even get a simple configuration with a local database up.

Hi @MCTMike

welcome to XWiki!

Can you show us the logs from /var/log/tomcat*X*/catalina.out?


I think I figured this one out.

I was trying to access the /xwiki URL from inside the server, which isn’t running a graphical browser. I tried cURLing the URL, and I tried installing the text-only ‘links’ browser, both of which failed. I switched to accessing it from off-instance on a computer with a GUI and a modern browser, and I’m off to the races.


Great. :slight_smile:
Please mark your answer as “solved”.

1 Like

I had similar issues with the 12% initializing message. For me the problem was with resouces (not enough memory or cpu on the VMs). Once these were increased the installation ran ok

1 Like