New Space after Migration

Hello all,

I migrated my xwiki from 7.1.4 to 9.4. I used the Nested Pages Migrator to get to the new structure.

It seemed to work pretty good but I have one major problem right now…

In the old environment I had spaces and pages under the space. And I could decide to either create a new space or a new page. But right now I’m always creating “Nested Pages” (which are emulated Spaces). The problem here is that I cannot create a new Space in the “root” directory to get it displayed correctly in my navigation panel (document tree standard navigation). So everytime I create a new space (which should be on the highest level to be a major topic (or in my case a department in our company)) it is created in the main space or in whatever space I’m in at the moment I create it…
So I don’t see a possibility to create a new “root” Space in our structure due to the fact that I cannot choose a “root” (should be the whole xwiki) to create the space under it.

I hope I described my problem clearly and maybe you could help me.

Thank you in advance
Timo Dachs-Wegmann

Hi, in case you haven’t read it please see It explains the new concepts related to Nested Pages.

Starting with XWiki 7.2+ you don’t create spaces anymore. You only create pages.

To create a new page as a root page, simply use the create button and make sure you set the correct location. If you start from the home page of your wiki, the default location will be a top level space. But anyway you can always edit the location independently from where you create the page from.

On the Create Page dialog click the tree icon to change the location, then select the wiki node (e.g. the root “Home”) in the page tree. Click on Select afterwards. The new location should look like Home / NameOfYourTopLevelPage.

As Vincent said, if you open the Create Page dialog from the wiki home page then the location is Home / NameOfYourTopLevelPage by default (so you don’t have to change it).

Hope this helps,

First of all, thank you for your answers.

@vmassol @mflorea
Yes, I’ve read the documentation and understood the new concept. That’s why I migrated my old structure to the new one. And I think there is the source of my problem because now I have a root scruture looking like this (screenshot from the create page -> select location window)


I want to create a new Page that acts like the others (EDV, Entwicklung, Vertrieb and so on). So in the old structure these where my spaces and I could create one if I needed to.
These are our departments so if we get a new one (for example split one department into two) we can’t define these pages to be “spaces” or “roots”.

I know I could pick for example “EDV” as a root and the page will be desplayed below but I don’t have a clue how to create a new page on the level of these six “spaces”/pages.

Thank you for taking your time and trying to help me.


What you have in the screenshot doesn’t look right. You’re missing the wiki node. We have this since 2 years ago so the tree from the Select Page modal should either show the current wiki as root node or show the list of wikis. In both cases you would be able to create top level pages by selecting a wiki node. Try to clear the browser cache and reload, but I doubt this is the problem.

Well, yes exactly that is my problem. And I don’t know why it doesn’t show me the root node.
In the old version the spaces work correctly and they can be displayed correctly in navigation etc…

I can show you my navigation panel as it is at the moment…

The point “Startseite” seems to be something like a root node because if I don’t select a special “Space”/page in the location window while creating a new site the site gets placed under this point.
But that is not at all how it should be…

The next problem I see with my new structure is that the document tree macro on a page doesn’t show the pages below but the whole “Xwiki” again.


{{documentTree root=“document:$doc.documentReference” /}}


So this code won’t do what I need. It only displays the whole content as you can see in the screenshot below.


Did you set the core.hierarchyMode property in to “parentchild”?

The core.hierarchyMode poperty is set to “reference” should it be “parentchild”? I thought this was the old hierarchyMode and should only be used if you want to use the old structure. But I wanted to migrate to the new one so I left it as it is (reference)

No, I just wanted to check if you’re using the old hierarchy mode. If you’re using the “reference” hierarchy mode then I don’t understand why the tree doesn’t show wiki. Can you try this on a separate wiki page:

== Show Root ==

{{documentTree showRoot=“true”/}}

== Show Wikis ==

{{documentTree showWikis=“true”/}}

Do you get the wiki nodes in the tree?

Hope this helps,

Yes, I don’t understand it either.
I tried your “code” on the EDV.WebHome page (which should display all pages below EDV including the EDV node)
but as you can see below in the screenshot… Same result as always. :frowning:


Still the same problem.

So I “fixed” it. As shown in the above posts the I had no root where everything should’ve been in but after installing a new server and importing everything I saw a possible reason for my problem.

The new imported structure (after nested page migration) had a “root” but the spaces were not under it.

So it was the same structure as I’ve already posted but the “Startseite” above was called “home” so when I created a new site without pointing anywhere it placed it under the “home” space.
So I moved every “space” (“Verwaltung, EDV, Entwicklung” and so on) under home and can now choose to create a new page under my “root” which I renamed to the name of the wiki.

So now my structure looks pretty good. Only some extensions I install place their sites on the same level as the root so I have to hide them to have a clean Navigation panel. But that is a workaround I can live with.

Thank you for your help and I hope if others have a problem like me this might help.