as part of my work on notification settings and more specifically on https://jira.xwiki.org/browse/XWIKI-18406 I changed the wordings especially when creating new custom filter to help users understanding what they’re doing. Now there’s an ambiguity on the wording if we should talk about events / events and notifications or just notifications.
To give you some context, we’re now talking about “Notification filters” that are triggered on “event types” and are related to “notification formats”.
I was starting to make changes so that we are talking about “Notification filters that applies on events types and locations to trigger proper notifications (with right formats)”. IMO we’re keeping clear that there’s both events and notifications, and the notifications are only created when the events are handled. This is technically accurate, and it also allows us to keep the wording “events” that we have at several places in the notifications settings (even in the name of some systems filters, such as “Minor event filter”).
Another solution proposed by @lucaa is to get rid of events and talk only about Notifications everywhere. This have the advantage to be more simple for users, now it means we probably need to do it everywhere in Notification settings in time.
Note that for now I’m focusing on the two livetables I worked on as part of https://jira.xwiki.org/browse/XWIKI-18406 and on the Add notification modal. Here’s the first screenshot I have for it:
So to sum up, my proposal is to keep Events and notifications in the wording of Notification settings for now, with the wording you can see in those screenshots.
@lucaa will probably comment this proposal with her own to keep only Notifications in the wording.
Note that this work (with the wording in screenshot) is already committed for 13.2RC1, we can of course improve later but I’d like to reach a first conclusion before the release date (which is planned for the 22nd of february).