No flavors listed in the distribution wizard

Installed 10.5 on tomcat, however there are no flavors listed. Downloaded and added to the repository, restarted tomcat - no changes. Can’t figure out what is wrong. The catalina.out is empy. Hm, how can I turn on the verbose debug mode, so I can at least see some warnings?
The connection to external repositories is ok.

Any hints?


Hi, I would start by trying to hard refresh your browser cache.

I clear the browser cache, use FF and Chrome also on from different computers, but this does not change anything. The xwiki looks like this and the destination wizard does not show any flavor :frowning:


I found that the flavor installation is a bit shaky too. Often it takes very long time (minutes) to have a flavor presented, with no progress indicator whatsoever. The best way I found is to wait a minute or two, then reload the page, eventually click on the “later” button and restart the app server. On the next attempt I mostly saw the flavors. And yes I’m talking about a reasonable fast internet connection, but with a proxy in between maybe it’s just the proxy for me that needs to get things sorted.

Honestly, I’m happy that this does not happen only to me :frowning:
I try to wait (more then 5min), clearing browser caches, restart the tomcat, but nothings happens. The Flavor is still missing.
I also download the package and unzip it into the extension/repository as described here.

However even this does not help.

Please any idea how to increase the debug level to be able to see what is happening on the tomcat/backend?

The installation is done on remote computer, where I have only limited rights and I have to ask admin for often for various permissions.

You should make sure the server where XWiki is running is allowed to access, you might find clue of that in the application server log (if access is blocked by some proxy for example you will find errors in it).

You meant, right ? You sure you use the XIP package with the same exact same version than your version of XWiki ? Make sure you are in the right folder (basically if extension/repository was not already existing then you are not in the right folder). Make sure you unzipped the content of the zip directly under extension/repository/ and not in some sub folder.

I guess you could open your network tab of your browser to check the calls to * and see if they worked or not.

Those requests are not made by the browser so you can’t see them on the Network tab.

I checked the access to the from the server and nothing is blocking it. I can run wget on the link and got the index.html dowloaded smoothly. So, this should be ok.
The xip package I’m using I download from the 10.5 download page.

Renamed to zip according to the instruction on the AdminGuide page.
The content is unziped directly to the extension/repository (already exists → it is the xwiki data dir).
I even enable the superuser account, restart the tomcat, but the distribution wizard still does not show to me any content.

Running out of ideas, what is wrong :frowning:

What is also strange, that I can’t see anything in the catalina.out log file.
The files is empty, even I reboot the tomcat.
I was expecting to see some messages at least some info like server going down and coming up again. But, nothing like this. The file is empty :frowning:
Any ideas what is wrong or how to at least push the server to be more verbose?

XWiki definitely produce some log at startup even when all is OK so you probably have some setup issue. Maybe you are not looking at the right file. Maybe each application have a dedicated log file in your setup ?

New version released today 10.6. I download it and install it on my vagrant env - ubuntu 16.4, java 8 - default-jdk,
sudo apt-get install xwiki-tomcat7-mysql
increase tomcat mem
restart tomcat
Got destination wizard -> empty! :frowning:

I destroy to the vagrant and recreated it from scratch again, however in this case with 9.4 version.
Result -> All is running fine. :+1:

So there must be something related to the distribution. Or, do I miss something?


One more update: I repeat the installation with version 10.0 and then also with version 10.4 and in both cases the destination wizard shows the desired Standard Flavor.
See the pictures bellow.

So, it looks like something is maybe wrong with the Flavor repository?



Comparing with 9.4 is not really relevant since it’s not based on flavors (flavors mode started in 9.5) but on a configured default UI indicated in the distribution.

I just tried with the “Zip Package” from and the flavor picker is working just fine for me. Seems to be related to your environment some way but the only things I can think of that prevent the flavor from displaying at least the XWiki Standard flavor are:

  • your browser lost connection with the XWiki instance for some reason (but I think you would get some error notification in that case), try to refresh
  • your XWiki instance cannot reach, since it just check that the flavor exist it generally appear very fast (for other flavors and actually validate them and check dependencies, etc)