No "Rights" Entry when editing a page (logged in as admin)


I have noticed that while connected as an admin some pages miss the “Rights” entry (see below captures in french):
Rights entry: OK

Rights entry: missing!

Can someone explain me this strange behaviour and tell me how to correct it?

Details: yet to change rights on some pages I need to go to [Wiki]/xwiki/bin/view/Main/AllDocs.
Example on my Wiki, the following pages have no “Rights” Entry:

The difference is between final pages (which have that right setup directly in Edit menu) and more classical pages for which you need to use the page administration (from … menu).

Indeed not nice from a usability POV… @evalica any idea? :slight_smile:

If you don’t have access to a certain feature we don’t display it. This is this case: because the page is terminal, or maybe you are in a wiki/space where you are not Admin, you will not see that entry in the menu.

Not sure @vmassol how we could ‘fix’ it, since IMO nothing is broken. Alternatives would be to display the entry grayed out, but that would crowd the UI and we cannot remove the concept of terminal pages.

@evalica: It’s a usability issue because users shouldn’t need to care or know whether a page is terminal or not and it’s not consistent to have menu actions done in different places for the same action.

A solution maybe would be to have the entry, but on:

  • spaces pages have link go to the normal WebPreferences
  • terminal pages have the link to to the parent WebPreferences + &section=PageAndChildrenRights.

This would ensure the UI consistency of that menu entry, but users might have confusion because the behavior will not be consistent: because of 1 to many affects.

Actually this is already the case in 10.9:

  • normal page Administratrion page
  • terminal page Administrationterminal

Indeed the terminal pages have also the Rights entry rights

So what we could do is remove the “Edit - Rights” entry and rely only on the Administration entry.
The related issue for this is

Thanks for your replies.

Is there an easy way to mark / unmark a page as terminal? I only see this option when creating or copying a page. Maybe by performing a rename with same name for page? (I can not perform tests: is slow even down?).

If the page is missing the “Droits d’acces” from the “Modifier” menu, means that that functionality will be available in the extra menu, in the “Administer” entry.

The functionality is not missing for terminal/non-terminal pages. It’s just that it is displayed in different places and indeed we should fix this.
On the other hand, the “Administer” option has more options than only the Rights.

What I see in next xwiki release from your screenshots looks good for me :+1:.

I personally find useful to always have a “shortcut” to rights in “Modifier” menu for both types page (terminal or “nested” / normal page) even if I agree with Vincent that it gives user two ways to perform the same action.

Please also pay attention to screens which allow user to manage rights: terminal page and “normal” page should have the “same” layout to manage page rights at page level only, and “normal” page should have additional option to define rights for children pages.

PS: I confirm that it’s easy to make a page terminal or not by performing a Rename of the page.

I don’t think this is in the next release :slight_smile: AFAIK you’re using (10.8.1) and thus you already have the latest UI and we didn’t change this in 10.9…

According to @evalica’s message we did.

I’m not sure @evalica said this. She said that in 10.9 she could see what she posted but it doesn’t mean it was done in 10.9. @evalica could you be more specific and maybe link to the jira issue? Thx

@tmortagne If we had done this in 10.9 it would be in the release notes and I can’t find it in . If we forgot we should add it. Maybe Marius did this when working on some other stuff?

So what I meant is that in the latest version (10.9) we have it, but I didn’t say we implemented now. Initially I didn’t know what version Richard had, so that’s why I mentioned the version I tested on. Later I deduced that was on 10.8.1.