Notfications UI Problem in Subwikis


we use xWiki Version 12.3 and after an update from 12.1 the notfications menu in the top-bar is “broken”.


The problem does not exist in the main-wiki.


Another obvious difference is the display of the Editors. Is that related?

Hope you can help.

Hi @jwielsch

we just performed a quick check on XWiki 12.3 with a subwiki to reproduce the notification problem, but apparently we don’t reproduce it.
Could you share the produced HTML that is breaking the notification? You might have had some specific changes on the page http://yourdomainxwiki/view/XWiki/Notifications/Code/NotificationsDisplayerUIX that led to this problem when upgrading to latest version.

I don’t think so, this looks like this issue:

hi @surli,

thank you very much for your fast respond.

code from broken notfication display:

<a href="<span class=" wikiexternallink"=""></a><a class="wikimodel-freestanding" href=""><span class="wikigeneratedlinkcontent"></span></a>

From the main-wiki:

<a href="/bin/view/XWiki/JWielsch?category=notifications" class="notifications-settings" rel="nofollow">
<span class="fa fa-cog"></span>&nbsp;Einstellungen

No changes werde made in http://yourdomainxwiki/view/XWiki/Notifications/Code/NotificationsDisplayerUIX

Here is the code:

    <span class="notifications-header-link">
      <a href="$xwiki.getURL($xcontext.userReference, 'view', 'category=notifications') class="notifications-settings" rel="nofollow">

I created a new subwiki within the xwiki and even in the new one the same problem occurs.

In this very moment i’ve found another problem: all the links in the notifications of the subwiki are directing to the wrong wiki. I edited a page in the main-wiki and, when clicking on the bell in the subwiki, the notfication-links are generated wrongly an direct to the subwiki.

Could you look at NotificationsDisplayerUIX history tab and compare the standard version of NotificationsDisplayerUIX with the current version.

Here the screenshot. I started with Version 12.0 on Feb 24 - an just tested if an upgrade to 12.4-rc1 solves the problem. So now the last version is from 12.4

You compared the “Version coming from extension” (first line in the history) and the last version of the actual history indicated as “Current version” on the right ? If that’s the case then there is definitely a problem since those should be identical and you should try to “Rollback” to the “Version coming from extension”.

Yeah. Great. I rolled back the page to the version 1.1 from Version 12.0 an everything works fine!

Even the links point to the right wiki.

Thank you very much!


just for the record:

today i updated xwiki to 12.4 stable and with the version of the extension manager the problem came back.

After rolling back the page to Version 12.0 everything works fine.

I tried different versions and the ones from 12.0 and 12.1 work fine - the newer ones not. Even if they come directly from the extension manager.

i can’t explain that behaviour.

I think I know what the problem is (using wiki=true in the html macro as shown in the diff you posted) and so it’s certainly a real bug. What you’re doing right now to “fix the issue” is actually a bad workaround: you cannot get the new changes bring to that module and you’re kind of lucky that it’s still working :slight_smile:

I’m surprised that I don’t reproduce immediately but it might be related to another factor. I’ll fix it for next release.

Thank you very much for staying tuned on the problem!

“lucky” is my second name :smiley:

it is working really good at the moment and i’ll try to switch to the latest version of the document after your investigation and the - probably needed - fix.

If I can do anything to help, just let me know.

Another question: Should I remove the “solved” badge from tmortagnes response? I do not want to be rude, but if it is the wrong way, it should not be there, as it may lead others to do the (wrong) same steps as me.

I switched to the latest version of the document and removed the wiki=true. It solves the problem.