Pages with mixed locales, how cleanup not wanted locales

Using XWiki 14.5

I am not a experienced XWiki user/admin.

So I created a subwiki, created pages and content and after a while I switched the default language (to German) without enabling the multilingual feature.
I did not notice the mix of German und English page, but in the solr search, the findings results are filtered and the English results are not enabled by default. And many users are very confused about this.

How can I switch easily the existing pages to German? There is no translation link/button on the information page of these pages.


One more time I answer my question myself :laughing:
I am a XWiki beginner.
I create a new wiki/subwiki. Start to create content, add some pages and a few days later the wiki is switched to another default language as English.
The problem or fuzzy configuration starts at the localization tab.
It is possible to set “mulitlingual=NO”, “supported languages=German, English” and “Default language=German”. This was the case for my wiki.
All pages created after this configuration change have “language=German”, and now the pages are mixed and the search results are very confusing, for people no aware of this situation.
Fixing the language attribute is not possible, with this configuration.

Setting “multilingual=YES”, makes it possible to change the language for each page, using the information page to get rid of this mixed situation.

But for inexperienced users it is hard to examine and understand this.

I think it is a “little” bad operator guidance in the localization config dialog.
It is even possible some really senseless configs like “mulitlingual=NO”, “supported languages= English” and “Default language=German”.

I think it will be better to disable the “supported languages” field, if “multilingual=NO” and is preset with the default language.

btw: is it possible to delete only one “localized” part of a page? My attempt to delete the English version of a page, deletes all of them :face_with_hand_over_mouth: :wink: