Problem with Xwiki on CentOS7after installation

Hello, while my Debian Setup with Xwiki isnt working yet i tried the CentOS for installing XWiki with this HowTo Guide

The Main Installation worked and i am able to open the Xwiki Page and login as admin etc…

But when i Reboot the CentOS VM the Webpage isnt available anymore. The Network Link is online i see that when i run the nmlci con show command, there are Two Connections, first the ens33 and second the virbr0 Device both “online”

When i open the Startpage http://linux.mydomain:8080/xwiki/bin/view/Main/ i get the reply

“Error Connection failed”

i do get it up running again if i go into cd /usr/local/“XWiki Enterprise 8.4.4” and rerun the bash command. The entries ive made as test are then still there and also a test user ive created. But i doubt thats a correct behave and procedure after vm reboot?

So id be glad if someone could point me to a possible solution or how i could evaluate the problem more in detail

Thanks in advance


Noone has a hint or idea what the reason could be?

kind regards


As I’m not familiar with this setup you have used (and depending the purpose of this wiki I suggest you reconsider), the easiest but also quick and dirty way to start it during reboot is to add the command to /etc/rc.local

Otherwise you would need to craft a service for your program to start …

Hello Beat_Burger, thanks for your advice.

ill take a look and see about the options :slight_smile:

kind regards