Save page closes Edit-Mode like Save&View


when we edit a page in version 12.6.1 and we save the page using the “Save” button and want to continue editing, the page will be saved, but it changes to the View-Mode (like Save&View was pressed).
This happens since we upgraded from 11.10(?) to 12.6.1 and using the new in-place-editing.

Did we miss some new configuration?


The goal of inplace editing is to look like the view mode! :slight_smile:

When you click Save, it’s still in edit mode (you can see that the save toolbar is still there for example).

You can still click in the content to edit it.

However I agree that it would be better that clicking “Save” would not remove the cursor location. Do you think you could raise a jira issue for this at XWiki Platform - JIRA ?


No, it’s not in editing mode anymore. The page reloads fully (the pagetrees get refreshed etc) and then i’m back in view-mode. There is no save-button anymore.

You should check the JavaScript console in this case, there’s probably a JavaScript error that breaks the in-place editing. The Save button works fine for me, and it seems the same applies for Vincent. Another things to try is to clear the browser cache and reload, considering that you recently did an upgrade.

Also, would be good to mention the browser you’re using.

It’s a matter of giving back the focus to the editor after clicking on Save. Should be easy to implement.

Sorry - tried it with Google Chrome 83 and Firefox 78.0, both having the same issue, even after clearing the browser cache again. We did the update about a week ago.

But i get some errors in the console, which looks like an invalid path to the rest-interface:

(meta.js?cache-version=1597424449000:1 Error while refreshing the version from URL //rest/wikis/xwiki/spaces/DWH/spaces/DWH01/spaces/das_ist_ein_test_mit_leerzeichen/pages/WebHome?media=json&timestamp=1599555585231 )
jquery.js:9175 GET https://rest/wikis/xwiki/spaces/DWH/spaces/DWH01/spaces/das_ist_ein_test_mit_leerzeichen/pages/WebHome?media=json&timestamp=1599555585231 net::ERR_NAME_NOT_RESOLVED

Strange - it works now…
I have removed the xwiki.home-entry and restarted the tomcat - now the javascript-errors are away and saving the page is working.

I’ve added the xwiki.home for another reason (mainly for testing a special behaviour), so it’s no problem for me now. But i don’t know if this is the real reason - why the rest-api-call had no server in the URL instead of the one in xwiki.home…
But anyhow - it works now.