Solr search - unable to install in 11.0.3, unsupported? ANY help appreciated

Hello, one day search in our xwiki disappeared completely. I couldn’t even see Solr in the “DEFAULT SEARCH ENGINE” select, it was empty. So I tried uninstalling and reinstalling Solr in the extensions page. I could uninstall it successfuly, but when trying to install it again I get an error, that this version is not compatible with my installation. But in the details of the Solr I can see, that it is compatible with mu installation 11.0.3.

Search is essential for me so ANY help is VERY appreciated. Thank you


Seems you’re trying to install te Solr Search Application version 11.2 inside a XWiki 11.0.3 installation and this cannot work. You need to install version 11.0.3 by clicking the 11.0.3 version link and then click install.

Now you shouldn’t need to install the SOLR Search app at all since that comes bundled with XWiki Standard. So you’re doing or have done something wrong somewhere… :slight_smile:

OK, that worked! Thank you, installation was successful, and I see all the Solr settings! But I still do not see the search bar as I used to… Maybe you have any idea where should I search for the problem?