Theme not applied when "Prevent unregistered users from viewing pages"

According to this Access Rights article, if we check the “Prevent unregistered users from viewing pages, regardless of the page rights or space rights” box, the themes won’t apply to the logon screen.
The solution mentioned there is “give view access to unregistered users on your Color Theme page”.

I’ve looked around, but can’t see this on the latest version (10.6.1).

Does anyone know how we can fix those permissions so when a user goes to our main page, they’re forced to authenticate and it shows the correct theme for that Wiki?

The method we have used here successfully is to allow “view” rights for the XWiki.XWikiGuest pseudo-user on the color theme and/or skin page you have applied on your wiki. You can use either rights editor (assuming you’re an advanced user) or the object editor. If I recall correctly, when in the Rights editor (the one with the grid of checkboxes) the unregistered user is called something special and floats up top as the first row.

It used to be well documented but it took some digging around the last time I encountered this very error.

Hmm. Maybe it changed in the new versions?
When I go to the theme and click on the administration menu, I only have the option to “Administer Parent”.
I have set the View permission for the “Unregistered Users” on the Parent and Children pages, but the logo is still missing.



From the documentation at

You should note that if you prevent unregistered users from viewing all pages there are currently some limitations:

  • Color Themes are pages and thus your current Color Theme won’t be accessible for unregistered users who’ll get the default Color Theme. To fix this, you’ll need to give view access to unregistered users on your Color Theme page.

Are you an advanced user (i.e., your user isn’t explicitly set to Simple)?
I don’t see the dropdown arrow next to Edit which makes me think you are not an advanced user. You should be able to use the Edit dropdown and select Rights then change the permissions for the page of the Color Theme you wish to show all users.

Hi @eban5,

Thanks for the additional info.
I changed an account to Advanced User and added the View permission for Unregistered Users, but it’s still not displaying the logo on the logon screen when the “Prevent unregistered users…” box is checked.
I’m not sure if this is a bug or something that’s exclusive to our instance.


Login Screen: