Trouble viewing output from Diagram Application (Pro)

Hi All,

I just downloaded XWiki to evaluate for our organization. I need to be able to create diagrams with embedded links so this is a critical feature.

I can create a simple diagram in Diagram Application (Pro) with an embedded link like in the top portion of the attached pic and it looks and works great. But when I send a link to the page to someone else, they see what’s shown in the bottom of the pic.

Any help would be greatly appreciated. Many thanks!

diagram_issue

Weird.

I cannot reproduce this problem.

I created a diagram on a test page, then I opened the link to a private browser session and it worked just as expected.

What version of xwiki do you have installed? Did you make any other changes to the default installation, such as with permissions?

Thanks for your help pd.

I’m using the cloud version so I assume it’s up to date.

I have given unregistered users view permission and myself all permissions. No other changes from default that I am aware of.

I get the same result across multiple PCs, browsers etc :frowning: