Unable to edit pages in XWiki

Recently, we have tried to update the xwiki to 16.4.0 which was running in docker with PostgreSQL in backend. During update due to network issue the update got corrupted and i’ve restored the old backup to it and xwiki running without any issue.

But while trying to edit any page it’s just loading only and seen some logs in docker console.

Docker Logs:

Your logs indicate some failing REST request related to the Blog Application, but these shouldn’t affect the editing of a plain wiki page. Have you tried to clear the browser cache and reload the edit mode? Also, check the JavaScript console from the browser’s developer tools, there might be exceptions logged there.

Hope this helps,
Marius

Hello @mflorea,

Thanks for your quick response.

I’ve deleted my browser cache and tried to edit the page and i’ve seen some error logs in console, can you please check those and suggest me the corrective action.

Hey Team,

Requesting to please help me on my issue.

Also, can we check xwiki version through database. If yes, please provide me the process to check.

Thanks.

@vmassol Hello Vincent,
Can you please help me by checking above mentioned issue.

Thanks.

I don’t know what’s your problem. The logs seem to suggest some error during your restore but since you didn’t mention details of what you backed up and how you did the backup nor how you did the restore, it’s hard to help you more.