Upgrade to 12.2 breaks Wysiwyg and Allow Realtime Collaboration


We currently are running docker-compose with postgres-tomcat with nginx proxy in front.
We haven’t had much issues will this release 12.2. We can edit documents with wiki, or text but not Wysiwyg. I didn’t get an error messages when rolling the update.

When selecting Wysiwyg to edit with there are no errors, just a white blank screen.

Allow Realtime Collaboration

When trying to run Collaboration get the following error
" We were unable to connect you to the realtime system.
You won’t be warned if other users want to edit the document collaboratively and you can’t join a collaborative session."
we usually ran Collaboration on port 8093

Hi. I doubt that the upgrade to 12.2 breaks the WYSIWYG. It seems you have some realtime extension installed though. Maybe it’s only this extension that is broken somehow?

Make sure you force clean you browser cache too (you can try in incognito mode to be sure too).

So cleared the cache then keep getting error pointing to this. found via developer console.

function(d,h){this.basePath=d;this.fileName=h;this.registered={};this.loaded={};this.externals={};this._={waitingList:{}}};CKEDITOR.resourceManager.prototype={add:function(d,h){if(this.registered[d])throw Error('[CKEDITOR.resourceManager.add] The resource name "'+d+'" is already registered.');var g=this.registered[d]=h||{};g.name=d;g.path=this.getPath(d);CKEDITOR.fire(d+CKEDITOR.tools.capitalize(this.fileName)+"Ready",g);return this.get(d)},get:function(d){return this.registered[d]||null},getPath:function(d){var h=
Error: [CKEDITOR.resourceManager.add] The resource name "keystrokes" is already registered. ckeditor.js:255:206
    add https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:255
    editorConfig https://website.tech/bin/get/CKEditor/Config?outputSyntax=plain&t=K3SE:8
    k https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:265
    k https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:266
    callback https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:254
    f https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:252
    n https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:253
    x https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:253
    load https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:254
    d https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:254
    callback https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:254
    f https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:252
    n https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:253
    p https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:253
    onload https://website.tech/webjars/wiki:xwiki/application-ckeditor-webjar/1.43/ckeditor.js:254

Could be interesting to uninstall (and clear cache) the realtime extension to diagnose if that’s the extension causing the problem.

BTW 12.3 is out now :slight_smile:

Yes wasn’t available this morning, but looks like 12.3 is up I’ll try that and get back

I cleared cache, tried in private mode, tried another browser all fail.

My guess is really that the realtime extension is causing problems as I don’t see how the normal wysiwyg could be an issue for the upgrade.

Do you have any custom CKEditor configuration? You should check the CKEditor administration section. Try to reset the configuration there to the “factory” settings.

Not sure how to reset back to factory I’ll look into that, but you are right I did a test with clean version of Xwiki 12.2 and 12.3 both work fine then imported data. I can import all data and works fine until I import CKEditor page then it breaks.

See https://extensions.xwiki.org/xwiki/bin/view/Extension/Extension%20Manager%20Application#HChanges

The CKEditor administration section http://extensions.xwiki.org/xwiki/bin/view/Extension/CKEditor+Integration#HAdministrationSection has a Reset button, which resets the CKEditor configuration. But the link @vmassol pasted is also useful to make sure that the CKEditor code is up to date (e.g. doesn’t have customizations).

I don’t understand what you mean by “import CKEditor page”. You don’t need to import anything in order to use the CKEditor.

Okay so found some issues one was server.xml needed to add the following.

  <Engine name="Catalina" defaultHost="localhost">
      <Valve className="org.apache.catalina.valves.RemoteIpValve"

The other issue was our advanced configuration. Doing the reset did work.