XWiki 11.10.8 Upgrade: Error Message During Deinstallation of Orphaned "Markdown - Common 1.1" Extension

That’s probably not critical, but it is to be expected, or did I do something wrong?

image

Also note the box below “Apply” which just says “job.status.warning” - this looks like an unresolved placeholder text.

Hard to tell if that’s normal or not but at least it looks specific to this extension. From what I understand the uninstall did its job from Extension Manager point of view so it should be OK.

Indeed, just fixed it.

I’m not sure because I don’t think that the MD extension does anything with Classloaders. It could be a generic XWiki issue since AFAICS the class should be available in the ClassLoader.

What is uninstalled by default is invalid extensions and extensions are generally invalid because they are missing a dependency, which explain the class not found.

Maybe there’s a missing dependency definition between extensions related to the Markdown plugin or so… I think I remember that during the upgrade before, something related to “markdown” was listed as being “unused”, so I allowed the upgrade process to uninstall it.

Unfortunately, I’m not quite sure though - it might also have been something related to the MediaWiki renderer which we recently installed and also uninstalled again.

So maybe there’s some dependency problem with the MediaWiki renderer… :-/ Sorry that I’m not of any real help here.

So I’ve tried to reproduce but couldn’t. Here’s what I did:

  • install XS 12.5.1, install Markdown 1.2 version 8.5.4, then upgrade it to 8.6
  • upgrade to XS 12.6-SNAPSHOT

The DW executed and the orphaned step executed:

Screenshot 2020-07-30 at 14.58.05

I selected all of them and clicked Continue and I got an error:

Screenshot 2020-07-30 at 14.58.53

I’ve reported https://jira.xwiki.org/browse/XWIKI-17601

But then I clicked continue and it said it worked:

Screenshot 2020-07-30 at 14.59.23