Xwiki 13.8 and WebLogic 12.2.1

Hi,
does anyone has suceeded in installing last Xwiki on Weblogic 12.2.1 or has some experiences with it?
I have some issues with it so first I am asking whether it is feasible with Xwiki 13.8.

On installation page there is mentioned: XWiki is a Java-based wiki and runs on a Servlet Container such as Tomcat, Jetty, JBoss, WebLogic, WebSphere, etc.
But weblogic is not mentioned on a page with supported, nor unsupported servlet containers.

Moreover on Java Support Strategy page I found that you were about to drop support for Java 8 (and Weblogic runs only on Java 8).

Thx for any comments

Yes, nobody has provided any WebLogic-specific instruction page. Now WebLogic is a servlet container so it’s sure that it can work with XWiki. Maybe you may need to provide some WebLogic configuration for example if WebLogic doesn’t isolate its own classpath from the webapp classpath (that’s a typical one for servlet containers).

In any case, if you need help, you should post the error you’re getting here. Maybe someone will recognize the problem and be able to help out.

I’d be very surprised that WL doesn’t run on Java 11. Just googled and found:

Oracle WebLogic Server 14c (14.1. 1.0. 0) is certified for use with JDK 11 , in addition to JDK 8.

Yes, but I was referring to Weblogic 12.2.1, which runs only on Java 8.

I am getting errors like these: (example just 5 of them)

<11.10.2021 15:12:57,652 CEST> <Unable to parse class file: zip:C:/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/AdminServer/tmp/.appmergegen_1633957959573/xwiki.war/lpldy/war/WEB-INF/lib/carte-util-3.5.1.jar!/module-info.class. >
<11.10.2021 15:12:58,285 CEST> <Unable to parse class file: zip:C:/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/AdminServer/tmp/.appmergegen_1633957959573/xwiki.war/lpldy/war/WEB-INF/lib/bcprov-jdk15on-1.69.jar!/META-INF/versions/11/org/bouncycastle/jcajce/provider/asymmetric/edec/KeyAgreementSpi$X448.class. >
<11.10.2021 15:12:58,344 CEST> <Unable to parse class file: zip:C:/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/AdminServer/tmp/.appmergegen_1633957959573/xwiki.war/lpldy/war/WEB-INF/lib/bcprov-jdk15on-1.69.jar!/META-INF/versions/11/org/bouncycastle/jcajce/provider/asymmetric/edec/KeyFactorySpi$Ed25519.class. >
<11.10.2021 15:12:58,473 CEST> <Unable to parse class file: zip:C:/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/AdminServer/tmp/.appmergegen_1633957959573/xwiki.war/lpldy/war/WEB-INF/lib/css4j-dom4j-3.6.0.jar!/module-info.class. >
<11.10.2021 15:12:58,481 CEST> <Unable to parse class file: zip:C:/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/AdminServer/tmp/.appmergegen_1633957959573/xwiki.war/lpldy/war/WEB-INF/lib/bcprov-jdk15on-1.69.jar!/META-INF/versions/11/org/bouncycastle/jcajce/provider/asymmetric/edec/BC11XDHPublicKey.class. >

I can see there jdk15, versions 11 - so it seems it has sth to do with Java versions. So first of all I wanted to make sure it is supported/feasible.

This means you’ll need to upgrade your WL instance, use another servlet container or you’ll have to stay on XWiki 13.x.

They seem to all be the same error. BTW are they errors or warnings? Do they prevent the deployment of the xwiki WAR or not? Did you google about the error to see what the internet has to say about it?

Thanks

I made a couple of experiments.

I tried Xwiki 13.7. - direct download of war - no success.
When I tried to build my own war from 13.7. - deployment in Weblogic was “successfull” (weblogic showed: Active). But in weblogic logs there were still these errors. But according to a comment they are not issue and can be ignored. When I ran it for the first time a configuration applet started loading, but it reached 92% and then it crashed. - In logs there were the same errors as here. But in my case I could not continue - it just crashed. When I put this war in Tomcat it worked with no problem, no errors.
Then I tried to build war from 13.8. But deployment on Weblogic did not succeed (UnsatisfiedDependencyException).
I tried to build war from 12.10.10 - deployment was ‘Active’, but it was not possibble to access the page - 404-NotFound and start configuration.
I tried to build war from 13.6. and 13.2 - the same behaviour as with 13.7.

So different versions with different results/behaviour on Weblogic. It seems Weblogic is not fully supported. Tomcat is supported, but when app runs on Tomcat it does not mean it can successfully run also on Weblogic. There are also some differences - e.g. when Tomcat processes headers it displays them in lowercase, Weblogic does not. Since it was not tested on Weblogic, one can not be sure it can successfully run. So that was the reason I first came up with a question, whether someone succeded in installing Xwiki on Weblogic.