[XWiki 16.4.0] Realtime WYSIWYG Collaborative Edition doesn't work anymore

Since my last related post [XWiki 16.2.0] New issue with Editor along with RT Collaborative Edition where @mflorea and @TomTheWise have brought insights and comments, we have updated to versions 16.3.x then 16.4.0, now the realtime edition does not work anymore at all. Only the message stating User is currently editing this page, do you want to force comes up.

  • Here is the list of related plugins installed, can you tell me if I should remove some of them or else?
  • Then I’ll add a screenshot to state that the xwiki-realtime option does not appear anymore either in the Admnistration section related to Edition options.

Screenshot 2024-06-07 at 10-55-01 Global Administration - XWiki

2024-06-07_12-07

About the above configuration, I tried to untick xwiki-realtime in the drop-down menu containing the list of extensions, I also tried the reset button located near the save button, but the xwiki-realtime still doesn’t appear as a choice to replace CKEditor.

Is CKEditor supposed to do the job by himself? I have tried that too, and could not get realtime editing between two different users.

Also about the part of the discussion related to in-place editing also in the previous post, it is not showing this behavior anymore although I have not changed the xwiki.properties related line. It is still setup on the original default:

#-# The default is:
# edit.document.inPlaceEditing.enabled = true

therefore now I am confused wether or not in-place editing should trigger a narrow edition line in new pages.
A detail : we have upgraded Debian to version 12 bookworm and replaced Tomcat9 with xjetty. This is the only other change I can think of.

Here is a test page in the sandbox:
Screenshot 2024-06-07 at 12-17-15 Editing In-place Editing mode 2

I also meet with the same Realtime WYSIWYG collaborative edition issue in our LTS installation which is now version 15.10.10.

What is similar in both installs : we use Debian 11 in both, and we have switched from Tomcat9 to Xjetty ( xwiki-xjetty-pgsql), and not yet in Debian 12.

Does someone know if it usually ok to use realtime edition with this setup?

Realitme Editing is no longer a standalone Editor it is now a plugin of the CKE editor. You have to untick xwiki-realtime from the disabled plugins. This way realtime editing now also works in place.

Force editing is still required and it will probably stay that way, until realtime editing is considered stable and enabled by default.

The XWiki Roadmap (XWiki.org) has exactly these points in them:

Type Key Summary Status Created Date
Improvement XWIKI-20191 Add the Source button for the Realtime editor Open 04-Oct-2022
Bug XWIKI-21625 You shouldn’t have to force the page lock to enter a realtime editing session Open 28-Nov-2023
New Feature XWIKI-22128 Enable realtime editing for the WYSIWYG editor by default Open 25-Apr-2024

If you use an reverse proxy you have to make sure that your reverse proxy configuration upgrades websocket connections.

1 Like

@TomTheWise Thank you very much for your kind help. This has solved my realtime editing issue on both installs.

I am still unsure if I should remove the extensions listed in the above screenshot, in the 16.04.0 XWiki edition?

While I am looking at the list of default disabled plugins, I would like to ask what the other disabled plugins do, and if they need to stay disabled for the time being?
Here is a new screenshot:
Screenshot 2024-06-07 at 17-36-29 Global Administration - XWiki

Thank you very much for your help.