XWiki doesn't seem to use the Mail configuration

After configuring our mail server information in the Admin -> Mail -> Mail Sending, it seems that XWiki isn’t using the provided values - when sending an email, the server logs show that it’s still trying to connect to localhost instead of the mail server.

We tried restarting the container, but the problem remains.

What are we doing wrong?


Hi @doodloo,

i’ve just setup the Mail Sending a few days ago, maybe i can help you.

  1. What exactly you have configured at “Mail Sending”?
    Could you made a screenshot?
    (But anonymize the real e-mail, username and server)

  2. Is the Port for SMTP correct?
    -> 25 for non encrypted
    -> 465 for SSL/TLS
    -> 587 for STARTTLS

  3. If your Mail server is using encryption (SSL, TLS, STARTTLS) you need to include this as option in the “ADDITIONAL PROPERTIES” section of “Mail Sending”


    • SSL: mail.smtp.ssl.enable=true
    • STARTTLS/TLS: mail.smtp.starttls.enable=true


Hi there @Dolo and thanks for taking the time.

Everything is configured properly - we know because when we use the “Share Page” feature, people receive the email.
We discovered that the problem occurs when using the “Invite” functionality, and our settings are not used.

We use the mail.gandi.net server on port 587, and yep we have the SSL and TLS negociation flags set already.

Any idea?

Best regards.


i checked my configuration under Administer Wiki > Users & Rights > Invitation
and it seems that it is possible/needed to configure the SMTP settings again there (?)

Here is a screenshot:

Probably you need to configure the SMTP Server also there?


Maybe you have a mail configuration defined for the Invitation Application, which overrides the default mail config? See https://extensions.xwiki.org/xwiki/bin/view/Extension/Invitation%20Application#HConfiguringamailserver


1 Like

Hi there @Dolo and @vmassol,

Thanks - I think this was the problem. It’s worth mentioning that I never touched the Invitation application settings - so maybe it should inherit the global configuration in future releases…

Best regards,

It’s supposed to do just that. See the doc:

The mail server configuration extends the configuration given in the General section so if you have a mail server already configured, you can just make all of the fields empty.

If you had no value set in the overridden fields, then there’s a bug and it would be great to report it at https://jira.xwiki.org.


@vmassol Clearly a bug then, yes.

I just started a fresh install to confirm - this is what the Invitation configuration looks like after I configured the Mail options:


As you can see, it still has localhost as the host value, and I never entered that. Will report it.

Thanks for the help!

I also comfirm what fresh installation have localhost:25 as SMTP in invitation application.