XWiki Github Branch "stable-11.0.x" does not reflect latest 11.0.3 version


#1

Hi XWiki Team,

I’m trying to build a fresh XWiki instance from sources, cloning it from Github and focusing on the latest stable version 11.0.3.

I’ve cloned xwiki-platform again and I could check that the version in root pom (and all the others) is set to the 11.0.1-SNAPSHOT version, and not the latest stable 11.0.3. Is it indeed the correct expected value? My generated war results in 11.0.1-SNAPSHOT on version.properties. If it’s wrong, could you fix for us, please?

Another related question is how is the proper way to handle the Distribution Wizard error about the “SNAPSHOT” dependency not compatible when selecting the corresponding Flavor, when deploying a war built from sources. Testing with 11.0.1 flavor (the war’s version I could build from cloned github), I get:

Dependency [org.xwiki.platform:xwiki-platform-oldcore-[11.0.1]] is not compatible with core extension feature [org.xwiki.platform:xwiki-platform-oldcore/11.0.1-SNAPSHOT] ([org.xwiki.platform:xwiki-platform-oldcore/11.0.1-SNAPSHOT]) 

I think I’ll get the same error on whichever extensions I try to install from the repos, since the dependencies requires the non “SNAPSHOT” versions for the installed wiki, right? How can I handle this?

Finally, I’m running it on Wildfly 14 (deployed with success) and I could also notice on server’s logs that when Distribution Wizard starts to search for the proper Flavor, a gazillion of the following INFO statement appears. Is it the expected behavior? Anything I can do about it? (I’m using “/portal” as context root for xwiki, set on jboss-web/xml)

INFO  [io.undertow.servlet] (http://127.0.0.1:8080/portal/rest/jobstatus/flavor/search/wiki%3Axwiki) RestletServlet: [Restlet] Attaching application: org.xwiki.rest.internal.XWikiRestletJaxRsApplication@7d57714f to URI: /portal/rest
13:24:21,329 INFO  [org.restlet.Component.XWikiRestletJaxRsApplication] (http://127.0.0.1:8080/portal/rest/jobstatus/flavor/search/wiki%3Axwiki) Starting org.xwiki.rest.internal.XWikiRestletJaxRsApplication application
13:24:21,491 INFO  [org.restlet.Component.LogService] (http://127.0.0.1:8080/portal/rest/jobstatus/flavor/search/wiki%3Axwiki) 2019-02-06	13:24:21	127.0.0.1	-	127.0.0.1	8080	GET	/portal/rest/jobstatus/flavor/search/wiki%3Axwiki	-	200	-	0	160	http://127.0.0.1:8080	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0	http://127.0.0.1:8080/portal/bin/distribution/XWiki/Distribution?xredirect=%2Fportal%2Fbin%2Fview%2FMain%2F
13:24:21,661 INFO  [org.restlet.Component.LogService] (http://127.0.0.1:8080/portal/rest/jobstatus/flavor/search/wiki%3Axwiki) 2019-02-06	13:24:21	127.0.0.1	-	127.0.0.1	8080	GET	/portal/rest/jobstatus/flavor/search/wiki%3Axwiki	-	200	-	0	3	http://127.0.0.1:8080	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0	http://127.0.0.1:8080/portal/bin/distribution/XWiki/Distribution?xredirect=%2Fportal%2Fbin%2Fview%2FMain%2F
13:24:21,790 INFO  [org.restlet.Component.LogService] (http://127.0.0.1:8080/portal/rest/jobstatus/flavor/search/wiki%3Axwiki) 2019-02-06	13:24:21	127.0.0.1	-	127.0.0.1	8080	GET	/portal/rest/jobstatus/flavor/search/wiki%3Axwiki	-	200	-	0	3	http://127.0.0.1:8080	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0	http://127.0.0.1:8080/portal/bin/distribution/XWiki/Distribution?xredirect=%2Fportal%2Fbin%2Fview%2FMain%2F
13:24:21,913 INFO  [org.restlet.Component.LogService] (http://127.0.0.1:8080/portal/rest/jobstatus/flavor/search/wiki%3Axwiki) 2019-02-06 .... ....

As always, thanks a lot for your precious help.
Ramon Brandão


#2

Indeed the 11.0.x branch is not up to date and yet the tag is here. Looks like the release script did merged the release modification to the branch. Checking that.
Note that it’s only xwiki-platform, commons and rendering looks OK.


#3

The version of the XWiki Standard flavor XWiki propose comes from the META-INF/extension.xed file by default and looks like you have a descriptor which is not in sync with your WAR for some reason. The one from the standard WAR is generated during the build using https://github.com/xwiki/xwiki-platform/blob/master/xwiki-platform-distribution/xwiki-platform-distribution-war/pom.xml#L87.


#4

Never seen this kind of log so not sure what it’s coming from. It looks like some access log.

In the standard WAR there is a WEB-INF/class/logback.xml file with some configuration (among other things the default log level is WARN for most non XWiki packages). Maybe you lost this file in your WAR or it’s not taken into account in Wildfly for some reason.